• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Illumina, cannot obtain connection
Hi All,

Since recently I cannot connect Illumina to the pilight server (pilight 7.0 stable on raspbian jessie). Using android 7.0 on a Samsung S6. Can the upgrade to Android 7.0 have to do with it?

Tried to rebuild the Illumina app with more recent libs, to no avail, produces the same error. My app development knowledge is unfortunately insufficient to debug.

When entering the correct server and port:
The app says in Dutch: "Kan niet met pilight verbinden". (cannot connect to pilight)
When entering a wrong port:
The app says: "Kan niet verbinden! Controleer je server en/of poortinstelling(en)"
(Cannot connect! Check server and/or port configuration(s)) and displays as if page is turned.

Conclusion: the app notices the correct port and server, because it gives a different error message and behaviour. But something deeper goes wrong.

Anybody an idea what this may be?
Can you see anything in the debug output of the pilight daemon (not Illumina)? Run pilight like this:
sudo pilight-daemon -D
This may be the same problem I have. Did you recently add stuff to your config? Illumina stopped working for me after adding several devices and rules. It seems that Illumina cannot handle a config bigger than around 20 Kbyte without any whitespace.

I reported this issue, but unfortunately it has not been fixed.
See here
For now, the pilight debug does not show anything different. I will reduce the config size as suggested by Niek tomorrow.
Just As Niek found a reduction of the config.json helped.
For those that can do more with the illumina app, the handshake fails when the pilight config.json file that was read goes a bit above 29370bits. This not my expertise, I tried to fiddle with the time-outs but that did not do the trick.

I reduced my file by translating the program variables in the pilight config.json to extremely small (a1..a99 or so).

So my hope is that someone with better illumina knowledge can find out why this handshake error occurs. If I know what to change I can do the rest.

Possibly Related Threads...
Thread Author Replies Views Last Post
  [Already fixed in 8.1.2] Loss of webserver-connection Ulrich.Arnold 34 6,179 08-02-2019, 02:25 PM
Last Post: curlymo
  WebSocket connection failed: One or more reserved bits gregnau 8 3,673 02-16-2018, 10:02 PM
Last Post: curlymo
Thumbs Up Newbie problems, usbnano connection and rsl366 pukington 1 931 02-14-2018, 07:36 PM
Last Post: pukington
  Windows HTTP connection andbehtls 1 1,468 01-14-2018, 02:24 PM
Last Post: bnk72
  [solved] another pilight ssdp missed connection on RPI segalion 2 3,649 08-24-2016, 10:51 PM
Last Post: Hauke
  [Solved] pilight 7.0 LAN interact connection - 2 Raspberrys mvasi90 4 2,620 07-10-2016, 03:50 PM
Last Post: mvasi90
  pilight-receive: NOTICE: no pilight ssdp connection found bumtheduke 10 14,133 03-29-2016, 10:58 AM
Last Post: pilino1234
  Python script for direct socket connection JurnD 15 20,248 08-28-2013, 09:42 PM
Last Post: JurnD

Forum Jump:

Browsing: 1 Guest(s)