• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
development, orangepi pc+, "no gpio-platform configured"
#1
Hi there!

I am trying to install the up-to-date development version on my orangepi pc+,
running Ubuntu 16.04.2 LTS, from: https://www.armbian.com/orange-pi-pc-plus/
Quote:Linux orangepipcplus 3.4.113-sun8i #28 SMP PREEMPT Thu Feb 2 02:01:28 CET 2017 armv7l armv7l armv7l GNU/Linux

Following the guide at:
https://manual.pilight.org/en/installation
in order to install the development version.

Installation went without a problem.
Running
Code:
pilight-daemon -H
shows me, that "orangepipc+" is supported by pilight, which looks very good Smile

Sadly, running the daemon with
Code:
pilight-daemon -D
results in:
Code:
pilight-daemon: INFO: version v7.0-187-g4dab624
pilight-daemon: ERROR: no gpio-platform configured
.....
DEBUG: garbage collected log library

So, i thought, perhaps compiling this would help*, but sadly the very same problem appears,
it does not recognize the platform running on.

Any ideas?



_____
* When compiling pilight on the orangepi pc+,
I ** ran into this error:
/home/opi/neu3/pilight/libs/polarssl/bignum.c: In function ‘mpi_mul_hlp’:
/home/opi/neu3/pilight/libs/polarssl/bignum.c:1129:1: error: r7 cannot be used in asm here

I solved this, by adapting pilight/CMakeLists.txt
with additional compiler options:
line 40
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -fomit-frame-pointer")

(information about this, from: https://tls.mbed.org/kb/development/arm-...n-asm-here )

** Ok, seems like this was addressed already
https://github.com/pilight/pilight/issues/179
 
Reply
#2
Search the website. There are enough threads about it. I almost never give feedback on nightly code because that would take me too much time.

Google:
"gpio-platform" site:forum.pilight.org
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  ERROR: The Broadcom 2835 GPIO 0 is not set to output mode stuckinger 10 259 05-07-2019, 09:11 PM
Last Post: curlymo
  Git active branches and development behrisch 9 247 01-21-2019, 09:09 PM
Last Post: behrisch
Bug Bug report: WIFI dongle stops when gpio_switch.gpio = 20 woutput 16 4,284 01-03-2018, 10:11 PM
Last Post: zackdvd
  Config issues from development to stable 8.0 terrar 5 1,171 10-28-2017, 09:56 AM
Last Post: curlymo
  AdHoc network with 2 Raspberry and 2 GPIO transmitter not working webdandy 29 5,391 09-06-2017, 02:39 PM
Last Post: wseifert
  pilight development installation -- failed / what is the secret? gneandr 5 2,341 02-04-2017, 10:06 AM
Last Post: gneandr
  Development Version kniazio 8 2,616 01-23-2017, 12:05 AM
Last Post: wo_rasp
  Reset of GPIO ports / Detection of mobile phone NormBot 1 1,170 09-02-2016, 08:30 AM
Last Post: wo_rasp
  invalid gpio range koos147 2 1,748 11-02-2015, 08:40 AM
Last Post: woutput
  GPIO for other application koos147 1 1,438 10-31-2015, 08:08 PM
Last Post: pilino1234

Forum Jump:


Browsing: 1 Guest(s)