• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight nightly does not start up, no log entries
#1
Hello all,
i have pilight nightly runing on a Pi3 with the lates raspian/firmware. Since a few days pilight does not start anymore. I think it was after the uptate to the latest nightly build.

My problem is, i can find any entries in the logs, neither in the pilight log, nor in the error or message log.
Code:
pi@HomePi:~ $ sudo service pilight start
pi@HomePi:~ $ ps ax | grep pilight
1207 pts/0    S+     0:00 grep --color=auto pilight
pi@HomePi:~ $

Code:
pi@HomePi:~ $ tail /var/log/pilight.log
pi@HomePi:~ $ tail /var/log/pilight.err
pi@HomePi:~ $
|/code]

So i have no idea, where i can search fr the issue. Has anyone a hint for me for further error diagnostic?

Best Regards
Thomas Pfaffinger


Attached Files
.zip   config.zip (Size: 1.82 KB / Downloads: 3)
 
Reply
#2
What happens if you try to run pilight in debugmode (pilight-daemon -D)?
 
Reply
#3
(06-03-2017, 01:25 PM)Niek Wrote: What happens if you try to run pilight in debugmode (pilight-daemon -D)?

Hello Niek,
thanks for the Hint. I think i have identified the problem: pilight-deamon will not be found on the system.

I have reinstalled pilight (purged all packages, aptitude clean & cleanup, reboot, update and then install it again) but the pilight deamon will not be found on the system.

How can i install him?

BR
Thomas Pfaffinger
 
Reply
#4
The pilight executables should be in /usr/local/sbin/

Code:
pi@RASPI2 ~ $ ls /usr/local/sbin
pilight-daemon  pilight-debug  pilight-flash  pilight-raw
pi@RASPI2 ~ $

If they aren't there, pilight apparently was not properly installed. Assuming that the installation package is complete, I think errors must have been displayed during the installation.

Btw. Over the years, I had several issues with programs due to corrupted SD cards, so it may be a good idea to check your card for errors.
 
Reply
#5
Hello All,

i found a "solution" for my problem. the first problem was, that /usr/local/sbin was write protected, also for root. I dont know why.

After i have solved this issue, i got he message, that the wiring platform was not supportes (or such things, dont know the exact wording)

I rolled back to pilight stable, and this problem was solved. But now i have the same problem as before. pilight cannot send me a mail, as i have no mailaddress as username and a "-" in my mailaddress.

So i hope, the nightly with the solved mail issue will be provided soon as the next stable version.

Best Regards
Thomas Pfaffinger
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  [Solved] pilight service crashing on first webserver access after reboot VrahoK 20 436 12-21-2019, 09:46 AM
Last Post: curlymo
  pilight-control modify values coolinx 16 563 11-13-2019, 08:02 PM
Last Post: curlymo
  Bug: double free or corruption in pilight-send blackzombie 12 547 10-07-2019, 08:15 PM
Last Post: blackzombie
  [Fixed] High CPU usage when pilight usb nano disconnects DieterK 1 254 08-13-2019, 05:43 PM
Last Post: curlymo
  pilight Nano USB interface curlymo 228 103,713 07-10-2019, 06:14 PM
Last Post: curlymo
  problems compiling pilight on Odroid C2 WitchDoctor 101 12,356 03-14-2019, 09:01 PM
Last Post: curlymo
  pilight 8 what chages for custom protocols? polo 11 3,384 02-15-2019, 06:22 PM
Last Post: polo
  Assert error in v8.1.3-nightly-d2ee2d0d Ulrich.Arnold 4 669 10-24-2018, 09:28 PM
Last Post: curlymo
  pilight-debug shows nothing minhdomanh 3 686 10-18-2018, 07:01 AM
Last Post: felfert
  pilight-send and pilight-daemon DieterK 0 674 06-20-2018, 12:44 AM
Last Post: DieterK

Forum Jump:


Browsing: 1 Guest(s)