• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
no gpio-platform configured
#1
"yesterday it worked ;-)"
And not only yesterday, but the last few years.

pilight todayrefuses to start, the reported errors:
[Jun 03 10:42:31:313160] pilight-daemon: ERROR: no gpio-platform configured
[Jun 03 10:42:31:328696] pilight-daemon: ERROR: could not initialize 433gpio hardware module

I am not aware of any changes, except for my weekly update/upgrade.

Executing "gpio readall" shows everything looks fine.

I have got no clue what this is. Reading the previous threads, reinstall of wiringpi nor downgrade of kernel did help.

pilight-daemon version v7.0-189-g010fa3e
Linux harijnwebnew 4.9.30-v7+ #1001 SMP Fri May 26 16:09:18 BST 2017 armv7l GNU/Linux

please help
 
Reply
#2
Search the forum, this question has been asked many times this week (and before).
 
Reply
#3
ok,

rpi-update 52241088c1da59a359110d39c1875cda56496764

AND

Going back to the "stable"version did it for me

Thanks
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Raspberry PI, gpio-ir-tx and pilight not starting lordslash 5 694 06-11-2019, 05:19 PM
Last Post: curlymo
  GPIO input -> starting a rule scootermacro 1 157 06-09-2019, 07:40 AM
Last Post: curlymo
  Segmentation fault wth gpio-platform raspberrypi1b1 meloen 12 1,152 09-10-2018, 07:44 PM
Last Post: curlymo
  [SOLVED] Home Assistant switch gpio segalion 5 765 09-10-2018, 12:39 PM
Last Post: segalion
  Help: switch a gpio switch with webcontrol on pilight stable segalion 7 2,897 07-31-2016, 03:32 PM
Last Post: playerhot
  AdHoc - GPIO RPI2 & OrangePI2 error powerich 5 2,244 04-07-2016, 08:22 PM
Last Post: powerich
  usb will reset gpio koos147 3 1,435 02-23-2016, 08:12 PM
Last Post: koos147
  [solved] can't get GUI configured, error "...config gui element #1 "xyz", device not pitpat 7 2,456 02-22-2016, 10:04 PM
Last Post: pitpat
Tongue Trying to activate relay/gpio with remote control 433 mhz Horst 3 2,392 02-15-2016, 05:35 PM
Last Post: Niek
  Raspberry Pi Compute Module: 48 GPIO byteruler 1 1,298 08-21-2015, 11:05 AM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)