• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Libwiringx dependecy
#1
Hello,

First, I'd like to say thank you to all the people involved in this project!

I have a question regarding installation of pilight:
I been trying to install pilight on Raspbian using the installation manual
(https://www.pilight.org/get-started/installation/).

Unfortunately, the installation fails either from the repository or from manual compilation.

It says
Quote:The following packages have unmet dependencies:
pilight: Depends: libwiringx (>= 2.0) but it is not installable
E: Unable to correct problem. you have held broken package

So I installed wiringX from the git:
Code:
mkdir build
cd build
cmake ..
make
cpack -G DEB
dpkg -i libwiringx*.deb

I however still get the error. What am I missing? Tongue

Thank you!
 
Reply
#2
Do you have both the nightly and stable repository enabled? That will fix the issue.
 
Reply
#3
Thanks, the issue was that for some reason the commands form the manual did not properly add the pilight repo to the sources. I had to manually nano the pilight.list Tongue
 
Reply
#4
Same issue here.
Latest freshly installed Raspbian Jessie image.
Followed manual.

/etc/apt/sources.list.d/raspi.list
Code:
deb http://apt.pilight.org/ nightly main

apt-get update && apt-get upgrade
apt-get install pilight

Code:
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pilight : Depends: libwiringx (>= 2.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

I need the nightly because of problems of pilight 7 stable with 4.9-kernel as discussed in other thread.
What can I do?
Thanks,
Heiko
 
Reply
#5
You should read the manual:
https://manual.pilight.org/en/installation
 
Reply
#6
(07-08-2017, 03:10 PM)curlymo Wrote: You should read the manual:
https://manual.pilight.org/en/installation

Did that!
I found out that both stable & nightly source lines have to be in:
/etc/apt/sources.list.d/pilight.list

Although manual states "add also", and I copy/pasted the black/white source code, there was only the nightly line in /etc/apt/sources.list.d/pilight.list

I know that I manually changed >> to > as I thought this was a typo.
Maybe that should be explained in the manual that >> is necessary.

Thanks for pilight,
Heiko
 
Reply
#7
As always with a manual, follow the exact steps, and if those don't work, consider things to be a typo.
 
Reply
#8
The problem is that the manual seems to be some kind of PDF.
Normally, I copy/paste commands, but with the PDF-file, line-breaks don't seem to work on windows and putty.

The manual is correct, the problem is it doesn't seem to be copy/paste-friendly as I am used to...
 
Reply
  


Forum Jump:


Browsing: 1 Guest(s)