• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Service doesn´t stop the daemon
#1
After some Problems with the Webserver, I installed pilight nightly from scratch.

Now I got a remarkable issue; The daemon is unstopable.
After a Service pilight stop, the webserver is responding and send/receive is working.

If I use pilight-daemon -D, the Daemon is clientizing:

Code:
root@Homecontrol:/home/pi# service pilight stop
root@Homecontrol:/home/pi# pilight-daemon -D
[Aug 04 16:37:01:665257] pilight-daemon: INFO: rule #1 dev-tv-check-on was parsed in 0.000874 seconds

....

[Aug 04 16:37:01:728895] pilight-daemon: INFO: rule #52 sz_lueften was parsed in 0.001142 seconds
[Aug 04 16:37:01:735042] pilight-daemon: INFO: version v7.0-201-g1bfeb6c
[Aug 04 16:37:01:735375] pilight-daemon: DEBUG: ssdp sent search
[Aug 04 16:37:01:841201] pilight-daemon: NOTICE: a pilight daemon was found @192.168.2.70, clientizing

Any Ideas, how to fix this?

On my node, just updated to the latest nightly, it seems to have the same issue.
 
Reply
#2
Can you again post your config?
 
Reply
#3
See attachment


Attached Files
.txt   config.txt (Size: 15.7 KB / Downloads: 7)
 
Reply
#4
Am I the only one with this Problem?
 
Reply
#5
No issues here.
 
Reply
#6
Hm. Don´t understand this.

I took a new pi 3, a new SDCard and installed everything from scratch. The only Thing "old" is my config.

If I type "Service pilight stop", I don´t get [ok], same with "Service pilight start" and if I use "pilight-daemon -D" it shows a running daemon on the IP of my Pi.

How can i kill the daemon?
 
Reply
#7
Can you try:
Code:
pkill -2 pilight
 
Reply
#8
This one killed everything:

Code:
[Aug 06 12:30:22:315379] pilight-daemon: INFO: no pilight daemon found, daemoniz                                                                                                                                                             ing
[Aug 06 12:30:22:328716] pilight-daemon: ERROR: cannot bind to socket port -2012                                                                                                                                                             020734, address already in use?

Can´t start the daemon again...
 
Reply
#9
Get´tin more strange.

Reinstalled my Second Node. Configured only raspi-config, WLAN0 and installed pilight... not working:

Code:
root@pool:/etc/pilight# pilight-daemon -D
Ungültiger Maschinenbefehl

My config is just plain:

Code:
{
        "devices": { },
        "gui": { },
        "rules": { },
        "settings": {
                "log-level": 6,
                "pid-file": "/var/run/pilight.pid",
                "log-file": "/var/log/pilight.log",
                "webserver-enable": 1,
                "webserver-root": "/usr/local/share/pilight/",
                "webserver-http-port": 5001,
                "webserver-cache": 1,
                "whitelist": "",
                "gpio-platform": "raspberrypi2"
        },
        "hardware": {
                "433gpio": {
                        "sender": 0,
                        "receiver": 1
                }
         },
        "registry": { }
}

And once again... untill i updatet last Sunday, everything worked fine.

Now, there is Trouble with the "unstopable daemon" on my Main Pi and my Node (as Extender) doesn´t work at all.

Very frustrating...

Something with the daemon goes teribly wrong
 
Reply
#10
I would suggest reverting to a previous version to see if that works.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  [Solved] pilight service crashing on first webserver access after reboot VrahoK 20 2,287 12-21-2019, 09:46 AM
Last Post: curlymo
  communication between main daemon and clientized daemon stops tomk 29 4,684 05-06-2019, 08:57 PM
Last Post: curlymo
  pilight-send and pilight-daemon DieterK 0 969 06-20-2018, 12:44 AM
Last Post: DieterK
  Chasing a Bug in daemon.c curlymo 2 1,575 12-13-2016, 12:48 AM
Last Post: wo_rasp
  pilight-daemon client in other subnet PT-Biker 1 1,214 12-11-2016, 09:42 PM
Last Post: curlymo
  pilight-daemon fails to start 2 of 3 times tietze111 4 2,541 12-11-2016, 09:06 PM
Last Post: tietze111
  pilight doesn't show the right status in webgui jurkla 8 3,377 11-17-2016, 09:41 AM
Last Post: gregnau
  pilight-daemon answers json request with html page michib 5 3,584 04-22-2016, 10:25 PM
Last Post: curlymo
Question [SOLVED]pilight-daemon: ERROR: config is not in a valid json format herrmeier 4 8,294 11-28-2015, 11:28 PM
Last Post: herrmeier
  Daemon hanging after sending raw derfrink 4 2,671 03-13-2015, 02:43 PM
Last Post: wo_rasp

Forum Jump:


Browsing: 1 Guest(s)