• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Service doesn´t stop the daemon
#11
How do I roll back to a previous Nightly-Version and wich Version Wohls you suggest?
 
Reply
#12
Run:
Code:
apt-cache policy pilight
Then
Code:
apt-get install pilight=XXXX
Where you replace XXX with one of the versions before 200. Also downgrade the webgui with the same procedure.
 
Reply
#13
Hmm... doesn´t work...

two times unmet depencies:

Code:
root@pool:/home/pi# apt-get install pilight=7.0.199-g616d7b1
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
pilight : Hängt ab von: pilight-webgui (>= 7.6) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Code:
root@pool:/home/pi# apt-get install pilight-webgui=7.5
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
pilight-webgui : Hängt ab von: pilight (>= 7.0) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

And if I downgrade to stable 7.0, half of my devices won´t work.

@curlymo: If you PM me an eMail-Adress, I´ll grant you SSH to my Pi to analyze the error.
As mentioned before: two freshly Pi-nightly-Setups, none is working...
 
Reply
#14
Try combining the two downgrade commands into one, because they each depend on the downgrade of the other package.

Code:
sudo apt-get install pilight=7.0.199-g616d7b1 pilight-webgui=7.5
 
Reply
#15
No, didn´t work either:

Code:
root@pool:/home/pi# sudo apt-get install pilight=7.0.199-g616d7b1 pilight-webgui=7.5
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
pilight : Hängt ab von: pilight-webgui (>= 7.6) aber 7.5 soll installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
 
Reply
#16
Second Problem solved. My Node-Pi seems to have an Hardware-fault. Changed the pi and the node came up.

Now it is only the "unstoppable daemon"...
 
Reply
#17
Code:
sudo apt-get download pilight=7.0.199-g616d7b1 pilight-webgui=7.5
sudo dpkg -i --ignore-depends=pilight-webgui pilight_7.0.199-g616d7b1_*.deb
sudo dpkg -i pilight-webgui_7.5_*.deb
 
Reply
#18
Hm. I hate downgrading. I´d rather like to suppoort you Fixing this error.
 
Reply
#19
Of course it's better to do this on a dev pi.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  [Solved] pilight service crashing on first webserver access after reboot VrahoK 20 2,287 12-21-2019, 09:46 AM
Last Post: curlymo
  communication between main daemon and clientized daemon stops tomk 29 4,684 05-06-2019, 08:57 PM
Last Post: curlymo
  pilight-send and pilight-daemon DieterK 0 969 06-20-2018, 12:44 AM
Last Post: DieterK
  Chasing a Bug in daemon.c curlymo 2 1,575 12-13-2016, 12:48 AM
Last Post: wo_rasp
  pilight-daemon client in other subnet PT-Biker 1 1,214 12-11-2016, 09:42 PM
Last Post: curlymo
  pilight-daemon fails to start 2 of 3 times tietze111 4 2,541 12-11-2016, 09:06 PM
Last Post: tietze111
  pilight doesn't show the right status in webgui jurkla 8 3,377 11-17-2016, 09:41 AM
Last Post: gregnau
  pilight-daemon answers json request with html page michib 5 3,584 04-22-2016, 10:25 PM
Last Post: curlymo
Question [SOLVED]pilight-daemon: ERROR: config is not in a valid json format herrmeier 4 8,294 11-28-2015, 11:28 PM
Last Post: herrmeier
  Daemon hanging after sending raw derfrink 4 2,671 03-13-2015, 02:43 PM
Last Post: wo_rasp

Forum Jump:


Browsing: 1 Guest(s)