• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] Sunriseset v7 fails after update and gives negative values

after apt-get dist-upgrade the stable pilight is failing on me.
Last few weeks we got a pilight update regurarly, functionality is returning after each update

Sunriseset not operational anymore, the pilight interface gives negative values after 1 day running.

Searched the forum , but found no hits on Sunriseset failures after last updates.

More users who see this behouviour ?

Will be fixed tonight.

Got a Web-gui update with update/upgrade.

After the update , we have server error,

Not Found
The requested URL / was not found on this server.

After dist-upgrade we get pilight core update but program is still broken

Not Found
The requested URL / was not found on this server.

pilight-daemon -D , no errors,
pilight log :

WARNING: (webserver) could not read /usr/local/share/pilight//index.htm

directory does not exists on server,

hope it helps

The webserver now runs at /usr/local/pilight/webgui/
Reading all the posts, it is nowadays very tricky to get pilight running.

changed the webserver-root folder :

"settings": {
                "log-level": 4,
                "pid-file": "/var/run/pilight.pid",
                "log-file": "/var/log/pilight.log",
                "webserver-enable": 1,
                "webserver-root": "/usr/local/pilight/webgui/",
                "webserver-http-port": 5001,
                "webserver-cache": 1,
                "gpio-platform": "raspberrypi2",
                "ntp-servers": [ "0.nl.pool.ntp.org", "1.nl.pool.ntp.org" ]

still same error in pilight.log

pilight-daemon: WARNING: (webserver) could not read /usr/local/share/pilight//index.htm
pilight-daemon: INFO: secured webserver started on port: 5002 (fd 16)

re-install pilight does not help

I wiil wait for new Main Package,

Somehow the config was not changed at the right place, because it's still trying to reach the old folder.

Version v7.0-230-g5199090 is working.

great job, pilight in operation again Smile

You're welcome, can you however still edit your posts according to the forum rules. Especially the lack of codes tags.

Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] Triggering generic_switch leads to segfault Ulrich.Arnold 19 4,843 10-23-2019, 09:03 AM
Last Post: Ulrich.Arnold
  ][solved]Segfault when retrieving big chunked http message Niek 21 8,468 11-29-2018, 03:17 PM
Last Post: curlymo
  'FUNCTION' undeclared, v7 compilation fails Niek 10 2,726 01-08-2018, 11:54 PM
Last Post: Niek
  [Solved] config.json not updated Niek 6 2,318 12-31-2017, 03:19 PM
Last Post: curlymo
  [Solved] callback not executing when dns lookup fails Niek 1 1,168 10-08-2017, 11:44 AM
Last Post: curlymo
  [Solved] Rules switching state based on another device state not working apartmedia 6 3,369 09-27-2017, 01:41 PM
Last Post: apartmedia
  [Solved] connection to main pilight daemon lost TopdRob 20 6,852 09-17-2017, 04:30 PM
Last Post: curlymo
  [Solved] dimmer protocol kaku_dimmer does not react on dimmervalue apartmedia 25 6,656 09-16-2017, 10:29 PM
Last Post: apartmedia
  [Solved] Webgui not working in IE Ulrich.Arnold 7 2,807 09-12-2017, 05:22 PM
Last Post: Ulrich.Arnold
  [Solved] Illegal Instruction? PekkaLahtela 50 17,449 09-06-2017, 01:18 PM
Last Post: apartmedia

Forum Jump:

Browsing: 1 Guest(s)