• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] dimmer protocol kaku_dimmer does not react on dimmervalue
#21
manually compiled version bbc388b on jessie (stretch coming soon).
this fixed the dimmer value issue for me.
so the protocol problem seems to be solved.

although the problem described in this thread does still exist, great job.

bbc388b is one comfortable step further... Smile

do you still need dimmer codes from an original remote?
Intertechno support was not very helpful so far regarding this...
 
Reply
#22
Yay,

Upto now I never built c-code from GIT before, so this was a nice exercise ;-)
  1. Executed ./setup.sh as my regular (non-root) user and stopped it after the dialog config. (to confine executables in this directory)
  2. Created pilight/build directory
  3. Did the [cd build;.. cmake] trick (had to install couple of missing build-dependencies)
  4. make (hey that 's what I remember from 10 years ago ;-) )
  5. Wait until compilation ended.
  6. sudo systemctl stop pilight
  7. sudo ./pilight-daemon -V
    pilight-daemon version v7.0-233-gbbc388b1
  8. sudo ./pilight-daemon
  9. Kakus are dimming to set levels again, Yay !!
Sorry for the exhausive compilation log, but its been a while since I did that kind of stuff.

Anyway dimming seems to work again, should be in the nightly tomorrow for a proper package installation, right?
Thanx a lot curlymo

regards,
Hans
 
Reply
#23
Package will be available tomorrow.
 
Reply
#24
@hansdej
What exactly was your cmake trick?
And why you stopped and did not use setup.sh for make and install?
I compiled yesterday and tested with using the setup script only.
It all went well without calling make on my own.
Hm...
 
Reply
#25
I wanted to contain any binaries from my own complation attempt to "at least" my user directory (leave out the sudo helps to achieve this), and preferrably further contained to my local clone of curlymo's pilight-development source. (19 years of Linux experience says: keep your own experiments as far as possible from the dpkg-managed system stuff Wink )

Hence I studied the setup.sh a little bit and guessed the cmake step would configure stuff sufficiently for a make of binaries "somewhere" (the build directory).
  1. cd build
  2. cmake ..
  3. make (without "install")
Fortunately, running the daemon from there (~/src/pilight/build/) was sufficient to confirm the return of succesful, parametrised dimming. (Good thing it also finds /etc/pilight/config.json when starting from there.)
 
Reply
#26
Great. Good to know. Thanx for explanation
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] Triggering generic_switch leads to segfault Ulrich.Arnold 19 1,769 10-23-2019, 09:03 AM
Last Post: Ulrich.Arnold
  regex mask for protocol options not working Niek 2 1,788 01-06-2019, 12:20 AM
Last Post: Niek
  Protocol options defined as JSON_ARRAY getting lost Niek 6 2,149 01-01-2019, 11:03 AM
Last Post: curlymo
  ][solved]Segfault when retrieving big chunked http message Niek 21 6,388 11-29-2018, 03:17 PM
Last Post: curlymo
  [Solved] config.json not updated Niek 6 1,666 12-31-2017, 03:19 PM
Last Post: curlymo
  [Solved] callback not executing when dns lookup fails Niek 1 792 10-08-2017, 11:44 AM
Last Post: curlymo
  [Solved] Rules switching state based on another device state not working apartmedia 6 2,625 09-27-2017, 01:41 PM
Last Post: apartmedia
  [Solved] connection to main pilight daemon lost TopdRob 20 4,733 09-17-2017, 04:30 PM
Last Post: curlymo
  [Solved] Webgui not working in IE Ulrich.Arnold 7 1,977 09-12-2017, 05:22 PM
Last Post: Ulrich.Arnold
  [Solved] Sunriseset v7 fails after update and gives negative values PPacman 7 1,822 09-06-2017, 06:25 PM
Last Post: curlymo

Forum Jump:


Browsing: 2 Guest(s)