• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
receiver only collects on first install
#1
Hello,

I have a raspberry pi 3 with raspbian strecht lite
I use a arduino nano usb with the sender and receiver. Sender works wel every time.
The receiver (RXB6 and I have 4 of them) gives me troubles.

The steps i do is

Code:
sudo su
echo "deb http://apt.pilight.org/ stable main" > /etc/apt/sources.list.d/pilight.list
wget -O - http://apt.pilight.org/pilight.key | apt-key add -
apt-get update
apt-get upgrade
apt-get install pilight
apt-get install php5-cgi
When I have done those stept i start a pilight-daemon -D.
My implus remote, alecto wsd-17 and KaKu doorbell are recognized.

When I cancel pilight-daemon -D and start it again those devices are not recognized anymore. Reboots, service start stop, changing the RXB6, nothing gives me received devices. Using the webgui for the impuls devices works. Also tried with various arduino nano's but no effect.

Anyone a clue?
 
Reply
#2
Update

From https://www.pilight.org/post/rewrite-backports-1-2-3 I added

'gpio-platform': 'raspberrypi2' to config.json
running pilight-daemon -D
canceling ctrl-c
running pilight-daemon -D
canceling ctrl-c
etc
works.
impuls remote weather station are recognized.
Rebooting rpi and nothing is recognized anymore.
 
Reply
#3
I have done a fresh install:

Code:
echo "deb http://apt.pilight.org/ stable main" > /etc/apt/sources.list.d/pilight.list
wget -O - http://apt.pilight.org/pilight.key | apt-key add -
apt-get update

apt-get install libwiringx-dev
apt-get install libwiringx
apt-get install libmbedtls-dev

apt-get install liblua5.2-dev

apt-get install build-essential
apt-get install cmake
apt-get install git
apt-get install dialog
apt-get install libunwind-dev
apt-get install libpcap-dev

git clone --depth 5 -b development https://www.github.com/pilight/pilight.git

cd pilight

chmod +x setup.sh

./setup.sh

ldconfig

service pilight start

added 'raspberrypizero' to config file.

webgui works 1 time (but does not switches lights), after restart nothing indeed
 
Reply
#4
(09-04-2017, 07:57 AM)buldogwtf Wrote: I have done a fresh install:

webgui works 1 time (but does not switches lights), after restart nothing indeed


I don't have a problem with de webgui. pilight-daemon -D and pilight-receive only collect on first install. After reboot both don't receive signals.
 
Reply
#5
Please give me steps that i can reproduce (based on the apt packages).
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  apt pilight org INSTALL.md outdated sirtet 4 664 03-26-2018, 08:00 PM
Last Post: sirtet
  433MHz sender - receiver problem EndruK 1 690 02-17-2018, 02:24 PM
Last Post: EndruK
  [solved] First install of pilight Zentia 19 7,569 11-07-2017, 08:01 AM
Last Post: Zentia
  RF transmitter and receiver library AaronDz 2 1,659 05-20-2017, 10:51 AM
Last Post: Niek
  How to use 315Mhz RF receiver/transmitter with pilight-debug? HONCHENG 2 1,158 05-03-2017, 07:32 AM
Last Post: HONCHENG
  Schalk FE3 receiver pelipeli 4 1,913 11-05-2016, 11:37 AM
Last Post: Libelle
  Pizero install buldogwtf 0 737 08-14-2016, 07:50 PM
Last Post: buldogwtf
Question brennenstuhl RCS 1000SN remote control not recognized by receiver droptix 15 5,030 08-01-2016, 02:06 PM
Last Post: droptix
  Example/'sample for receiver m0rph13 2 1,137 06-08-2016, 09:45 PM
Last Post: m0rph13
  Send and receiver at same time impossible geerttttt 5 1,663 06-03-2016, 11:58 AM
Last Post: wo_rasp

Forum Jump:


Browsing: 1 Guest(s)