• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Nightly Version 7.0.217 node not sending
Hi there,

just upgraded to Stretch and downgraded pilight to .217 (Same as on my main Pi)

My Node is not sendning out any Signals, altough pilight is up and running:

root@pool:/etc/pilight# service pilight status
● pilight.service - LSB: Starts pilight-daemon
   Loaded: loaded (/etc/init.d/pilight; generated; vendor preset: enabled)
   Active: active (exited) since Tue 2017-09-05 12:20:34 CEST; 22min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 294 ExecStart=/etc/init.d/pilight start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/pilight.service

Sep 05 12:20:32 pool systemd[1]: Starting LSB: Starts pilight-daemon...
Sep 05 12:20:34 pool pilight[294]: Starting : pilight.
Sep 05 12:20:34 pool systemd[1]: Started LSB: Starts pilight-daemon.
With pilight debug, I get some Error Messages about an BMP180, although there is no BMP180 soldered on my Node.

[Sep 05 10:46:44:756010] pilight-daemon: DEBUG: new thread bmp180, 5 threads running
[Sep 05 10:46:44:756262] pilight-daemon: ERROR: wiringX failed to open x▒rw for reading and writing
[Sep 05 10:46:45:756486] pilight-daemon: NOTICE: error connecting to bmp180
[Sep 05 10:46:45:756588] pilight-daemon: DEBUG: (probably i2c bus error from wiringXI2CSetup)
[Sep 05 10:46:45:756635] pilight-daemon: DEBUG: (maybe wrong id? use i2cdetect to find out)

My Node-Config:

        "devices": {},
        "rules": {},
        "gui": {},
        "settings": {
                "log-level": 6,
                "pid-file": "/var/run/pilight.pid",
                "log-file": "/var/log/pilight.log",
                "webserver-enable": 0,
                "webserver-root": "/usr/local/share/pilight/",
                "webserver-http-port": 5001,
                "webserver-cache": 1,
                "gpio-platform": "raspberrypi2"
        "hardware": {},
        "registry": {}

The Main Pi is sending out Signals and devices get switched.
Probably a Problem with UUID-Sending?

In my config, the device is connected to the UUID of my node:

"Poolpumpe": {
                        "uuid": "0000-74-da-38-382f5f",
                        "protocol": [ "elro_800_switch" ],
                        "id": [{
                                "systemcode": 31,
                                "unitcode": 2
                        "state": "on"

Watching pilight-receive Output, the Sender states the UUID of my Main-Pi, if I toggle the Switch:

        "message": {
                "systemcode": 31,
                "unitcode": 2,
                "state": "on"
        "origin": "receiver",
        "protocol": "elro_800_switch",
        "uuid": "0000-b8-27-eb-074060",
        "repeats": 4

Attachment removed by an administrator, you got a PM
I don't quite get what you are saying here Smile
I got two PI´s, one as a "Master", equipped with BMP180, DHT22, Sender and Receiver. UUID of the Master is 0000-b8-27-eb-074060.

The second Pi, my Node is only equipped with a Sender. UUID of the Node is 0000-74-da-38-382f5f.

Sockets near my Master are working fine, Sockets near my Node dont Show any reaction.

Of Course, on the previous Versions (before .200) everything worked.

Now I realised two remarkable things:

-pilight Daemon does some strange things with a BMP180 on my node, althought there is no BMP180 soldered to my Node

-If I use pilight-receive on my Master and Switch a socket wich belongs to my Node, I see this action with the UUID of my Master

A little bit more clear?? ;-)
And what was the working behavior you refer to?
The sockets near my Node were switching as expected.
The latest commit should provide working behavior.

1 Master and 1 node, the master has the following device configured.
        "devices": {
                "kerstlicht": {
                        "protocol": [ "kaku_switch" ],
                        "id": [{
                                "id": 123456,
                                "unit": 0
                        "state": "on"
As long as i don't set a UUID in this device, both the master and the node will send.

As soon as i do set the node UUID in for this device, only that node will send, if i set the master UUID, only the master will send.

That should be the expected behavior.

Possibly Related Threads...
Thread Author Replies Views Last Post
  [Fixed] Fast sending codes in a row not working apartmedia 12 5,502 08-19-2019, 04:58 PM
Last Post: curlymo
  REPLACE error with installation latest staging version Niek 4 1,039 06-30-2018, 06:07 PM
Last Post: curlymo
  [Solved] Nightly segfaults joe99 7 2,031 09-05-2017, 07:35 PM
Last Post: curlymo
  [Solved] pilight nightly not sending codes Cipher 10 3,829 08-24-2017, 09:25 PM
Last Post: curlymo
  [Solved] Problem Datetime latest nightly Alex 6 1,938 08-14-2017, 07:28 AM
Last Post: Alex

Forum Jump:

Browsing: 1 Guest(s)