• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] callback not executing when dns lookup fails
I installed the current development version (so using the new http library).

pilight-daemon version b3b0941

I noticed that the callback of an http_get_content call does not (always) execute if an error occurs. Possibly this applies to http_post_content too, but I did not check.

I verified this behaviour by making a deliberate mistake in the url in wunderground.c. After that, I could see an errrormessage:
[ Oct 07 10:26:57:39252] pilight-daemon: NOTICE: getaddrinfo: api.wundergroundx.com, Name or service not known
The callback should then receive a non 200 code and log a notice "could not reach api.wundergroundx.com", but the callback is not being executed at all.
Should be fixed. Thanks for reporting. Will backport when travis succeeds.

Possibly Related Threads...
Thread Author Replies Views Last Post
  [SOLVED] Triggering generic_switch leads to segfault Ulrich.Arnold 19 4,484 10-23-2019, 09:03 AM
Last Post: Ulrich.Arnold
  ][solved]Segfault when retrieving big chunked http message Niek 21 7,823 11-29-2018, 03:17 PM
Last Post: curlymo
  no callback on some http requests Niek 20 8,029 07-28-2018, 10:22 AM
Last Post: Niek
  'FUNCTION' undeclared, v7 compilation fails Niek 10 2,630 01-08-2018, 11:54 PM
Last Post: Niek
  [Solved] config.json not updated Niek 6 2,185 12-31-2017, 03:19 PM
Last Post: curlymo
  [Solved] Rules switching state based on another device state not working apartmedia 6 3,215 09-27-2017, 01:41 PM
Last Post: apartmedia
  [Solved] connection to main pilight daemon lost TopdRob 20 6,299 09-17-2017, 04:30 PM
Last Post: curlymo
  [Solved] dimmer protocol kaku_dimmer does not react on dimmervalue apartmedia 25 6,301 09-16-2017, 10:29 PM
Last Post: apartmedia
  [Solved] Webgui not working in IE Ulrich.Arnold 7 2,650 09-12-2017, 05:22 PM
Last Post: Ulrich.Arnold
  [Solved] Sunriseset v7 fails after update and gives negative values PPacman 7 2,392 09-06-2017, 06:25 PM
Last Post: curlymo

Forum Jump:

Browsing: 1 Guest(s)