• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight-daemon on LEDE ?
#1
Hi,

today I upgraded my WNDR3700-V2 (running on Atheros AR7161) from OpenWRT 15.05 to LEDE 17.01.4, which is on Linux OpenWrt 4.4.92 kernel. But I recognized that my pilight-daemon version v7.0-119 is no more compatible with LEDE... (while other binaries I was running previously on OpenWRT run flawlessly on that LEDE version).

Is there anybody who can help me to get pilight-daemon running on OpenWRT successor LEDE ?

Thx in advance for your help…
 
Reply
#2
Can you describe the problem?
 
Reply
#3
Sure Smile. When I run pilight_daemon I get an error message:

Code:
root@OpenWrt:~> pilight-daemon
-ash: pilight-daemon: not found

the error message is contributed to the fact that pilight_daemon expects 2 libraries to be there.
Under OpenWRT 15.05 these are symbolic links to their respective versions. So if you do on 17.01:

Code:
root@OpenWrt:~> ln -s /lib/libc.so /lib/ld-uClibc.so.0
root@OpenWrt:~> ln -s /usr/lib/libpcap.so /usr/lib/libpcap.so.1.3

you get the following:

Code:
root@OpenWrt:~> pilight-daemon
Error relocating /usr/sbin/pilight-daemon: __fgetc_unlocked: symbol not found
Error relocating /usr/sbin/pilight-daemon: __assert: symbol not found
Error relocating /usr/sbin/pilight-daemon: __fputc_unlocked: symbol not found
Error relocating /usr/sbin/pilight-daemon: __ctype_b: symbol not found
Error relocating /usr/sbin/pilight-daemon: fcntl64: symbol not found
Error relocating /usr/sbin/pilight-daemon: __uClibc_main: symbol not found

This simply might be contributed to the fact that OpenWRT 15.05 comes with v0.9 of libc and v1.3 of libpcap
while OpenWRT/LEDE 17.01 comes with 1.1 of libc and v1.3 of libpcap

Thanks for your help !!
 
Reply
#4
The best solution would be integrating pilight in the build scripts of LEDE / OpenWRT. I never took the time to investigate that, but are you willing and capable to do so?
 
Reply
#5
willing... yes. Smile
capable... not sure about that. Wink

I will give it a try on one of the next weekends, following the approach of https://forum.pilight.org/Thread-How-to-...WRT-Router and see how far I get...
 
Reply
#6
I would suggest checking this guide:
https://wiki.openwrt.org/doc/devel/packages
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Real 433Mhz Remote is disturbed by pilight service henne111 2 136 10-06-2019, 06:18 PM
Last Post: wo_rasp
Tongue (solved) pilight 8.1.5-1-gc0a175e0 Chrashes fleisch 5 551 10-03-2019, 01:15 PM
Last Post: fleisch
  Starting pilight on boot: "cannot bind to the SSDP multicast network" pilino1234 4 326 09-29-2019, 02:08 PM
Last Post: tomk
  pilight for Raspbian Buster (raspberry pi 4) ? starob 29 2,385 07-15-2019, 08:45 PM
Last Post: curlymo
  pilight-receive Filteroption not working Alex 2 556 07-14-2019, 08:35 AM
Last Post: Alex
  pilight usb nano format conversion ettman8 2 441 07-14-2019, 08:32 AM
Last Post: curlymo
  pilight 8.1.4 crashes after some hours Ulrich.Arnold 47 2,652 06-29-2019, 08:58 PM
Last Post: curlymo
  Raspberry PI, gpio-ir-tx and pilight not starting lordslash 5 845 06-11-2019, 05:19 PM
Last Post: curlymo
  pilight fails starting on boot Alex 5 740 06-09-2019, 06:02 PM
Last Post: curlymo
  Google Assistant coupled to pilight hansrijn2 4 1,227 05-29-2019, 06:54 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)