• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[solved] Webgui 404-Error
#1
Hello @All,
i have upgraded to pilight 8. After this, i got the error message:

WARNING: (webserver) could not read /usr/local/share/pilight//index.php

every time i want to access the webgui, anf there i got an 404-Error. In my opinion this is completly correct, because the index.php is not in the pilight or in the pilight-webgui package.

But how i can change the behavior of piligt, to access the index.html and not the index.php?

BR
Thomas Pfaffinger
 
Reply
#2
What does the config setting "webserver-root" contain in your config.json? Note that the path of the default webgui was changed with pilight 8.0 as documented here:
http://manual.pilight.org/configuration/...erver-root
 
Reply
#3
Hello pilino,

some times it is so easy. That was the problem. Thank you.

BR
Thomas Pfaffinger
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
Question pilight nightly webgui offline after some hours fleisch 4 144 10-26-2020, 05:19 PM
Last Post: fleisch
  Webgui offline after some hours scootermacro 19 1,248 06-03-2020, 08:16 AM
Last Post: scootermacro
  rpi3 Buster Compile Error Nikau 9 1,624 03-26-2020, 08:47 AM
Last Post: tvdgeer
  [Solved] pilight service crashing on first webserver access after reboot VrahoK 20 3,061 12-21-2019, 09:46 AM
Last Post: curlymo
  ERROR: The Broadcom 2835 GPIO 0 is not set to output mode stuckinger 10 2,283 05-07-2019, 09:11 PM
Last Post: curlymo
  v8.1.3 compile error without https fourty2 3 1,124 11-21-2018, 08:02 PM
Last Post: fourty2
  Assert error in v8.1.3-nightly-d2ee2d0d Ulrich.Arnold 4 1,203 10-24-2018, 09:28 PM
Last Post: curlymo
  WebGUI emtpy since 8.0.8 Dergo 14 4,208 02-24-2018, 01:09 PM
Last Post: Dergo
  CONTACT devices | Webgui wupperpi 2 1,170 01-18-2018, 03:37 PM
Last Post: wupperpi
  [Solved] No ssdp connection found Hexcode 145 169,364 12-23-2017, 02:10 PM
Last Post: HuberDe

Forum Jump:


Browsing: 1 Guest(s)