• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
REST API no systemcode supported
#1
I am installing the ha bridge with pilight and came to an issue, that the rest api does not support systemcode.

I use some logilink switches and when i type in
Code:
http://192.168.0.158:5001/send?protocol=logilink_switch&system=412774&unit=5&state=on
i get
Code:
{"message":"failed"}

every protocol with id and unit works but no protocol with system and unit is working.
Isn´t it implemented?
 
Reply
#2
The parameters are called "systemcode" and "unitcode", not "system" and "unit", so your command should be:

Code:
http://192.168.0.158:5001/send?protocol=logilink_switch&systemcode=412774&unitcode=5&state=on
 
Reply
#3
On the example in the Manual the example says this:
Code:
http://x.x.x.x:5001/send?protocol=kaku_switch&state=on&id=1&unit=1
and this works on systems with unit and id.
Your example does not work... and i still tested this before with
Code:
http://192.168.0.158:5001/send?protocol=logilink_switch&systemcode=412774&unit=5&state=on
http://192.168.0.158:5001/send?protocol=logilink_switch&system=412774&unitcode=5&state=on
http://192.168.0.158:5001/send?protocol=logilink_switch&system=412774&unit=5&state=on
but nothing works.
 
Reply
#4
In none of your examples you've tried systemcode and unitcode
 
Reply
#5
Quote:In none of your examples you've tried systemcode and unitcode
Sorry, naturally i testet the code pilino1234 posted. And it is not working either.
But i came to what i want by switching to run command (pilight-send ...) instead of run html in ha bridge and now everything works fine, because ha bridge and pilight are running on the same pi.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Rest-API kaku_contact wupperpi 5 1,309 12-07-2018, 09:26 PM
Last Post: curlymo
  nodered / Rest-API wupperpi 1 1,017 07-06-2018, 02:06 PM
Last Post: wupperpi
  vers.6 vs 7 -- improved REST API? gneandr 5 2,934 07-28-2015, 08:50 PM
Last Post: gneandr
  API -- usable with REST / Authentication (v.5.0) gneandr 7 6,679 07-25-2014, 10:42 PM
Last Post: gneandr
  Wiki page with supported devices. lvdp 4 2,640 01-09-2014, 12:07 AM
Last Post: lvdp

Forum Jump:


Browsing: 1 Guest(s)