• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Smartwares switch SH5-RBU-04A and SH5-RBS-04A doesn't work with 8.0.3
#11
Hi all,

this thread is somewhat older but I hope there are still people interested in it.
I've bought a smartwares SH5-RBS-10A switch and are experiencing the same problems: It's detected by pilight as an arctech_switch but none of the arctech_switch protocols is working.
I played around with the raw protocol and working/not working messages and was able to narrow down the issue to one pulse:

The second start pulse in arctech_switch.c is defined as
Code:
    arctech_switch->raw[1]=(9*AVG_PULSE_LENGTH);
but for the smartwares switch it should be
Code:
    8*AVG_PULSE_LENGTH

This is the only thing in a not working message generated by pilight that I have to change in order to make it work.

As I have no clue how to add a new protocol to pilight, is there someone who can add this?

TIA str
 
Reply
#12
Let us first check if the lower start pulse will work for archtech_switches as well.
 
Reply
#13
Hi,
i am new at pilight and i am interested too at a solution with the smartwares switch.
I tested kaku-switch and intertechno_switch and also the manual compiled pilight version but no protocol works fine.
As i can see switching "on" always works correct but switching "off" isn't always detected.
The most time i need several tries to switch off the smartware switch.

I am looking forward to get a solution from the pros.

Greetings,
Fatmax
 
Reply
#14
Hi,
I've build a custom version of pilight with the change I suggested in the previous post made to the arctech_switch.
For me this works fine, I would be happy if someone can test it with other smartwares devices as well as with intertechno and/or kaku switches.
You can get my test version from github and have to build it manually. Follow the instructions in the manual but get the source from here:

Code:
git clone --depth 10 -b smartwares_switch https://www.github.com/sreinelt/pilight.git

After building pilight you can test it with (replace the values for -i and -u with the ones used by your switch):

Code:
On: pilight-send -p intertechno_switch -i 27853102 -u 1 -t
Off: pilight-send -p intertechno_switch -i 27853102 -u 1 -f

I would be happy to get feedback on this.
 
Reply
#15
Hi str,
i tested it with your code but i have the same problem.
"on" command always works fine, "off" command doesn't work always.

I have 3 switches mounted in my living room.
Unit 1 (nearest to sender) and 2 (middle to sender) always works perfect.
At unit 3 (it's the switch with the longest distance from sender to switch, but it has visible sight -> no walls between) only "on" commands work perfect. "off" command only works sometimes (eg. from 10 trials it works 1).

I also tried to place the sender near the switches. It doesn't bring a better result, same problem.
I have also a remote socket (i switch this with protocol elro_800_switch) next to the same distance of unit number 3 and this always works perfect, therefore i don't think the distance is the problem.

Do you have any other idea?

Greetings,
Fatmax
 
Reply
#16
What type of smartwares switch do you have?
 
Reply
#17
(09-27-2017, 05:55 PM)str Wrote: What type of smartwares switch do you have?

The switches are: SH5-RBS-10A


Greetings,
Fatmax
 
Reply
#18
Hi,

So it is the same like mine. Strage - mine is now switching on and off without problems.
Have you tried sending the off command with the raw protocol and varying the different pulse type length?

Br, str
 
Reply
#19
(09-27-2017, 07:11 PM)str Wrote: Hi,

So it is the same like mine. Strage - mine is now switching on and off without problems.
Have you tried sending the off command with the raw protocol and varying the different pulse type length?

Br, str

Sorry, i don't know how to send in raw and change the pulse type length.
 
Reply
#20
The suggested patch works fine here. Let's see if we can get both scenario's working in this thread before i update the code.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Etekcity Switch geokscott 2 759 07-11-2019, 03:48 PM
Last Post: hepcat72
  SW-R01 / Geekbes Wireless Lights Switch gogosjon 0 332 10-13-2018, 05:29 PM
Last Post: gogosjon
  Switch Mumbi m-FS300 display as arctech-switch Rschnauzer 7 1,166 03-24-2018, 07:13 PM
Last Post: Rschnauzer
  Intertek with DIP Switch compuman1 12 7,956 01-15-2018, 07:59 PM
Last Post: madmoses
  Voltomat switch aszepeshazi 1 2,861 12-05-2017, 02:55 AM
Last Post: Archimdes
  [Work in Progress] Rev Ritter aevh 169 74,422 11-22-2017, 06:33 PM
Last Post: curlymo
  REV Switch Typ 8342L madeluxe 4 3,508 08-02-2017, 05:08 PM
Last Post: Flotto
  [Work in progress] somfy controller sandoz 128 43,925 05-06-2017, 10:38 AM
Last Post: wo_rasp
  DS-4 protocol (magnetic switch, EV1527 deviation) torwag 2 1,262 04-23-2017, 10:02 PM
Last Post: curlymo
  Smartwares SH5-RBU-04A Switch pati 9 5,939 01-31-2017, 09:22 AM
Last Post: wo_rasp

Forum Jump:


Browsing: 1 Guest(s)