• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WebGUI emtpy since 8.0.8
#11
Indeed. Development is what it is. Development != necessarily stable.
 
Reply
#12
(02-20-2018, 10:00 PM)Niek Wrote: So something went wrong with that installation. How did you install 8.09?

Just
sudo apt-get update && sudo apt-get dist-upgrade

Maybe it is necessary to install iteratively?

So not directly pilight_8.0.4_armhf.deb -> pilight_8.0.9_armhf.deb
but 8.0.4 -> 8.0.5 -> 8.0.6 -> 8.0.7 ->8.0.8 -> 8.0.9 ?
 
Reply
#13
(02-20-2018, 11:48 PM)Dergo Wrote:
(02-20-2018, 10:00 PM)Niek Wrote: So something went wrong with that installation. How did you install 8.09?

Just
sudo apt-get update && sudo apt-get dist-upgrade

Maybe it is necessary to install iteratively?

So not directly pilight_8.0.4_armhf.deb -> pilight_8.0.9_armhf.deb
but 8.0.4 -> 8.0.5 -> 8.0.6 -> 8.0.7 ->8.0.8 -> 8.0.9 ?

I am afraid that I don't know the answer to that question. I am only using pilight development manually compiled.
@curlymo, can you shine your light on it?
 
Reply
#14
(02-20-2018, 11:47 PM)curlymo Wrote: Indeed. Development is what it is. Development != necessarily stable.

Ofc. I know that. But if the documentation is leading, it is confusing for me that you apparently intentionally moved the root folders in a commit for development on September 2, 2017, but did not do the same for the master branch.

Anyway, if the root folders are supposed to be in /usr/local/lib/pilight instead of /usr/local/pilight/,  then this is a bug in the development branch.
 
Reply
#15
It is working again!
But actually I do not know exactly why... This is what I did:
I tried to downgrade with "sudo apt-get install pilight-webgui=8.0 pilight=8.0.4" but this did not work due to dependency issues (on each other?!). After that there was an error in the log which was not there before: "pilight-daemon: ERROR: uv_custom_poll_cb: bad file descriptor". So I rebooted. After that pilight did not start at all. The reason was that the config.json shrinked to null bytes. So it replaced it with the former config.json, only pilight.version.current updated in there to 8.0.9. After that pilight started! And, the config.json was automatically completed by the new fields.
Everything working now again, WebGUI, app and REST service...
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  CONTACT devices | Webgui wupperpi 2 834 01-18-2018, 03:37 PM
Last Post: wupperpi
  [solved] Webgui 404-Error PT-Biker 2 1,112 11-11-2017, 09:49 AM
Last Post: PT-Biker
  pilight doesn't show the right status in webgui jurkla 8 2,782 11-17-2016, 09:41 AM
Last Post: gregnau
  pilight WebGui not working after reboot Frank_a 7 4,875 02-04-2016, 09:11 AM
Last Post: wo_rasp
  [pilight 7] Got no buttons on the WebGUI Nachtwind 2 2,538 07-29-2015, 08:16 PM
Last Post: Nachtwind
Question [nightly build] getting datetime in webgui questor 1 2,152 12-29-2014, 03:46 PM
Last Post: curlymo
  webgui/ssh very slow .. high cpu usage gneandr 1 2,532 10-01-2014, 06:43 PM
Last Post: creamers
  Help needed, webgui not loading -Solved- puuhapet 18 13,292 09-16-2014, 09:58 AM
Last Post: puuhapet
  Webgui: iPhone/iPad icons Nelus82 24 9,605 04-04-2014, 11:22 PM
Last Post: curlymo
  webGUI - setting to ON or OFF .. not Toogle gneandr 3 2,050 03-14-2014, 05:56 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)