• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem FOR
#1
I am using several Rules to ventilate my basment depending on Outside Temperature as this example states: 

Code:
 "keller_morgens_kino": {
                        "rule": "IF ((zeit.hour == 7 AND zeit.minute == 0 AND zeit.second == 0) AND weather1.temperature < sensor_kino.temperature) THEN switch DEVICE keller_kino TO on FOR 40 MINUTE",
                        "active": 1
                },

Problem is, that switching to on if both conditions are true is working properly, but the device is not switching to OFF after the given MINUTE.

If I remove the AND-Condition, the DEVICE is switched to OFF after the given time, but with AND-Condition, it stays ON all day Long.

Any Idea, what might went wrong?

Thanks a lot!
 
Reply
#2
Have you checked if the problem perists in the latest pilight version? And what AND condition did you remove to get it working?
 
Reply
#3
(05-17-2018, 05:43 PM)curlymo Wrote: Have you checked if the problem perists in the latest pilight version? And what AND condition did you remove to get it working?

Yes, just today.

For Example:

Code:
 "aqluft_frueh": {
                        "rule": "IF (zeit.hour == 7 AND zeit.minute == 0 AND zeit.second == 0) THEN switch DEVICE aqluft TO on FOR 10 MINUTE",
                        "active": 1
                },

aqluft is working as expected.

Code:
"keller_morgens_wama": {
                        "rule": "IF ((zeit.hour == 7 AND zeit.minute == 41 AND zeit.second == 0) AND weather1.temperature < sensor_wama.temperature) THEN switch DEVICE keller_wama TO on FOR 40 MINUTE",
                        "active": 1
                },

keller_wama stays on all day and is shown "On" in Gui all day.

Devices implicated:

Code:
"zeit": {
                        "protocol": [ "datetime" ],
                        "id": [{
                                "longitude": 13.15,
                                "latitude": 52.66
                        }],
                        "year": 2018,
                        "month": 5,
                        "day": 17,
                        "hour": 7,
                        "minute": 50,
                        "second": 35,
                        "weekday": 5,
                        "dst": 1
                },
 "sensor_wama": {
                        "protocol": [ "tfa30" ],
                        "id": [{
                                "id": 37
                        }],
                        "temperature": 21.2,
                        "humidity": 64.0
                },
"weather1": {
                        "protocol": [ "tfa30" ],
                        "id": [{
                                "id": 50
                        }],
                        "temperature": 13.2,
                        "humidity": 81.0
                },
"aqluft": {
                        "uuid": "0000-b8-27-eb-074060",
                        "protocol": [ "elro_800_switch" ],
                        "id": [{
                                "systemcode": 23,
                                "unitcode": 2
                        }],
                        "state": "off"
                },
 "keller_wama": {
                        "uuid": "0000-74-da-38-3ed605",
                        "protocol": [ "elro_800_switch" ],
                        "id": [{
                                "systemcode": 28,
                                "unitcode": 2
                        }],
                        "state": "on"
                },
 
Reply
#4
You are definitely not using the latest pilight version, because your rule syntax is not valid in that version Wink
 
Reply
#5
I´m using the latest installable Version:

Code:
root@Homecontrol:/home/pi# apt-cache policy pilight
pilight:
  Installiert:           8.0.10
  Installationskandidat: 8.1.0
  Versionstabelle:
     8.1.0 500
        500 http://apt.pilight.org stable/main armhf Packages
     8.0.10-42-ga1279212 500
        500 http://apt.pilight.org nightly/main armhf Packages
 *** 8.0.10 500
        500 http://apt.pilight.org stable/main armhf Packages
        100 /var/lib/dpkg/status

Code:
root@Homecontrol:/home/pi# apt-get upgrade
Paketlisten werden gelesen... Fertig
Abh▒ngigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete sind zur▒ckgehalten worden:
  pilight pilight-webgui
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 2 nicht aktualisiert.
 
Reply
#6
That's not what i asked Smile
 
Also, i don't read german.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Problem with executing bash script via rule/program dYna 1 871 02-15-2018, 09:06 PM
Last Post: dYna
  Problem with a Rule for a One Button Switch martin-dj 1 1,211 03-06-2017, 12:01 PM
Last Post: pilino1234
  Sunriseset problem switches on at 0:00 kgulti 13 3,690 12-26-2016, 08:08 PM
Last Post: PekkaLahtela
  Problem: understanding rule ktams 6 3,051 09-07-2015, 10:37 AM
Last Post: ktams
  Problem switching device off after 20 minutes jurkla 3 1,722 08-28-2015, 08:54 AM
Last Post: jurkla

Forum Jump:


Browsing: 1 Guest(s)