• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] mbedtls_ssl_handshake: SSL - Processing of the ClientHello ha
When trying to get the secure webserver running on a raspberry 3 with raspbian-stretch I get this notice:

pilight-daemon: NOTICE: 

mbedtls_ssl_handshake: SSL - Processing of the ClientHello handshake message failed

followed by:

mbedtls_ssl_handshake: SSL - The connection indicated an EOF

What should I do or check regarding this error?
pilight version?
(08-06-2018, 04:43 PM)curlymo Wrote: pilight version?

I retried it on the latest version today: pilight-daemon version v8.1.2-nightly-ad7adc79

same result unfortunately.

btw I could not specify a pemfile with: "pem-file": "/etc/pilight/pilight.pem", ( config setting "pem-file" is invalid) so let it default: -rw-r--r-- 1 root root 5069 aug  7 15:18 /etc/pilight/pilight.pem
How can I reproduce?
(08-07-2018, 02:31 PM)curlymo Wrote: How can I reproduce?

When exploring further I saw the browser (Google Chrome) stating the connection is not private. And as I overrule the security messages I get a good connection, over HTTP, not HTTPS. So something was wrong with the certificate. 

When using Firefox it became clear that I used a self-signed certificate which is by default rejected but can be overruled. This then gives a https connection when this self signed certificate is accepted.

So, I am using a lesser good certificate. Consider the matter closed.

Possibly Related Threads...
Thread Author Replies Views Last Post
Question [Solved] Openweathermap with pilight 7.0-40 doesn't work Seebueb 2 545 01-01-2020, 06:45 PM
Last Post: Seebueb
  [Solved] Strange receive problem with 433Mhz Receiver and pilight 8.1.5 vanillaice30 15 1,418 12-18-2019, 11:09 AM
Last Post: vanillaice30
Tongue (solved) pilight 8.1.5-1-gc0a175e0 Chrashes fleisch 5 1,213 10-03-2019, 01:15 PM
Last Post: fleisch
  Solved - On / Off Command is the same command tigrablue 11 1,300 07-23-2019, 11:24 AM
Last Post: curlymo
  [solved] kwmobile: repeating the remote signal doesn't work dawncrow 9 1,524 10-25-2018, 03:46 PM
Last Post: dawncrow
  ["SOLVED"] Not able to control intertechno ITR-1500 Kambaramba 12 2,362 10-03-2018, 05:52 PM
Last Post: curlymo
  [solved] raw and debug Traeumer 2 790 09-27-2018, 09:43 PM
Last Post: Traeumer
  [SOLVED] Home Assistant switch gpio segalion 5 1,343 09-10-2018, 12:39 PM
Last Post: segalion
  smtp / solved Traeumer 7 1,152 08-21-2018, 08:47 PM
Last Post: curlymo
  [SOLVED] pilight wont start since update from 8.0.8 to 8.1.2 pukington 5 2,276 08-08-2018, 05:34 PM
Last Post: curlymo

Forum Jump:

Browsing: 1 Guest(s)