• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight 8 Rules no running
#1
Sad 
hi my English is not so good, i am translated by google 

in pilight 8 the rules do not want to work,
I always get the message

IF Rollo_WZ_1_Hoch.state == ...
    ^ unexpected symbol
[Aug 07 20: 34: 41: 99719] pilight-daemon: INFO: rule # 1 Rule1 was parsed in 0.000100 seconds

my config.json looks like this

{
    "devices": {
        "Rollo_WZ_1_Kopf": {
            "uuid": "0000-b8-27-eb-378df9",
            "protocol": [ "gpio_switch" ],
            "id": [{
                "gpio": 1
            }],
            "state": "off"
        },
        "Rollo_WZ_1_Hoch": {
            "uuid": "0000-b8-27-eb-378df9",
            "protocol": [ "relay" ],
            "id": [{
                "gpio": 8
            }],
            "state": "off",
            "default-state": "on"
        },
        "Rollo_WZ_1_Stop": {
            "uuid": "0000-b8-27-eb-378df9",
            "protocol": [ "pollin" ],
            "id": [{
                "systemcode": 1,
                "unitcode": 1
            }],
            "state": "off"
        },
        "Rollo_WZ_1_Runter": {
            "uuid": "0000-b8-27-eb-378df9",
            "protocol": [ "relay" ],
            "id": [{
                "gpio": 9
            }],
            "state": "off",
            "default-state": "on"
        },
        "Rollo_WZ_1_Leer": {
            "uuid": "0000-b8-27-eb-378df9",
            "protocol": [ "pollin" ],
            "id": [{
                "systemcode": 1,
                "unitcode": 1
            }],
            "state": "off"
        }
    },
    "rules": {
        "Rule1": {
        "Rollo_WZ_1_1": {
            "rule": "IF Rollo_WZ_1_Hoch.state IS on THEN switch DEVICE Rollo_WZ_1_Runter TO off AND switch DEVICE Rollo_WZ_1_Hoch TO off AFTER 10 SECOND",
            "active": 1

            "active": 1
        }



    },
    "gui": {
        "Rollo_WZ_1_Kopf": {
            "name": " Rollo Wohnen 1",
            "group": [ "Wohnen" ],
            "media": [ "all" ],
            "readonly": 1
        },
        "Rollo_WZ_1_Hoch": {
            "name": "Rauf",
            "group": [ "Wohnen" ],
            "media": [ "all" ],
            "readonly": 0
        },
        "Rollo_WZ_1_Stop": {
            "name": "STOP",
            "group": [ "Wohnen" ],
            "media": [ "all" ],
            "readonly": 0
        },
        "Rollo_WZ_1_Runter": {
            "name": "Runter",
            "group": [ "Wohnen" ],
            "media": [ "all" ],
            "readonly": 0
        },
        "Rollo_WZ_1_Leer": {
            "name": " ",
            "group": [ "Wohnen" ],
            "media": [ "all" ],
            "readonly": 1
        }
    },
    "settings": {
        "log-level": 6,
        "pid-file": "/var/run/pilight.pid",
        "log-file": "/var/log/pilight.log",
        "webserver-enable": 1,
        "webserver-root": "/usr/local/share/pilight/webgui",
        "webserver-http-port": 80,
        "webserver-cache": 1,
        "gpio-platform": "raspberrypi3"
    },
    "hardware": {},
    "registry": {
        "webserver": {
            "ssl": {
                "certificate": {
                    "secure": 0,
                    "location": "/etc/pilight/pilight.pem"
                }
            }
        },
        "pilight": {
            "version": {
                "current": "8.1.2"
            }
        }
    }
}


the rule with == does not work either
 
Reply
#2
Start by reading the forum rules
 
Reply
#3
danke für den hinweis

leider nicht die Lösung oder eine Sinnige Antwort auf mein Problem


thanks for the note

unfortunately not the solution or a sensible answer to my problem
 
Reply
#4
I know, but if you post on this forum we expect you to follow the forum rules. As soon as you did I will answer your questions.

And since this is an English forum, posting in German is of not much use.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight for Raspbian Buster (raspberry pi 4) ? starob 32 7,572 08-10-2020, 09:12 AM
Last Post: simanuel
  pilight switch node in node-red framp 0 261 06-24-2020, 10:01 PM
Last Post: framp
  pilight-control TML 13 963 05-27-2020, 07:51 AM
Last Post: curlymo
  Control Rules by Web GUI scootermacro 1 192 05-10-2020, 09:30 AM
Last Post: curlymo
  API Requests by HTTP from other devices fore use in pilight scootermacro 2 449 05-10-2020, 08:19 AM
Last Post: scootermacro
  pilight-send seems successful but doesn't actually send RF signal ayeyebrazov 37 3,238 03-31-2020, 01:02 PM
Last Post: curlymo
  pilight 8.1.5 not working on Raspberry pi after reboot beejayf 4 896 03-08-2020, 12:14 AM
Last Post: beejayf
  pilight cpu usage possibly associated with noticeable sluggishness? hepcat72 4 947 01-28-2020, 08:02 PM
Last Post: hepcat72
  apt.pilight.org stable Release' is not signed. thomasol 2 980 01-23-2020, 11:34 PM
Last Post: thomasol
  pilight and SIGNALduino cc1101 Caleus 0 731 01-19-2020, 09:13 AM
Last Post: Caleus

Forum Jump:


Browsing: 1 Guest(s)