• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight 8 Rules no running
#1
Sad 
hi my English is not so good, i am translated by google 

in pilight 8 the rules do not want to work,
I always get the message

IF Rollo_WZ_1_Hoch.state == ...
    ^ unexpected symbol
[Aug 07 20: 34: 41: 99719] pilight-daemon: INFO: rule # 1 Rule1 was parsed in 0.000100 seconds

my config.json looks like this

{
    "devices": {
        "Rollo_WZ_1_Kopf": {
            "uuid": "0000-b8-27-eb-378df9",
            "protocol": [ "gpio_switch" ],
            "id": [{
                "gpio": 1
            }],
            "state": "off"
        },
        "Rollo_WZ_1_Hoch": {
            "uuid": "0000-b8-27-eb-378df9",
            "protocol": [ "relay" ],
            "id": [{
                "gpio": 8
            }],
            "state": "off",
            "default-state": "on"
        },
        "Rollo_WZ_1_Stop": {
            "uuid": "0000-b8-27-eb-378df9",
            "protocol": [ "pollin" ],
            "id": [{
                "systemcode": 1,
                "unitcode": 1
            }],
            "state": "off"
        },
        "Rollo_WZ_1_Runter": {
            "uuid": "0000-b8-27-eb-378df9",
            "protocol": [ "relay" ],
            "id": [{
                "gpio": 9
            }],
            "state": "off",
            "default-state": "on"
        },
        "Rollo_WZ_1_Leer": {
            "uuid": "0000-b8-27-eb-378df9",
            "protocol": [ "pollin" ],
            "id": [{
                "systemcode": 1,
                "unitcode": 1
            }],
            "state": "off"
        }
    },
    "rules": {
        "Rule1": {
        "Rollo_WZ_1_1": {
            "rule": "IF Rollo_WZ_1_Hoch.state IS on THEN switch DEVICE Rollo_WZ_1_Runter TO off AND switch DEVICE Rollo_WZ_1_Hoch TO off AFTER 10 SECOND",
            "active": 1

            "active": 1
        }



    },
    "gui": {
        "Rollo_WZ_1_Kopf": {
            "name": " Rollo Wohnen 1",
            "group": [ "Wohnen" ],
            "media": [ "all" ],
            "readonly": 1
        },
        "Rollo_WZ_1_Hoch": {
            "name": "Rauf",
            "group": [ "Wohnen" ],
            "media": [ "all" ],
            "readonly": 0
        },
        "Rollo_WZ_1_Stop": {
            "name": "STOP",
            "group": [ "Wohnen" ],
            "media": [ "all" ],
            "readonly": 0
        },
        "Rollo_WZ_1_Runter": {
            "name": "Runter",
            "group": [ "Wohnen" ],
            "media": [ "all" ],
            "readonly": 0
        },
        "Rollo_WZ_1_Leer": {
            "name": " ",
            "group": [ "Wohnen" ],
            "media": [ "all" ],
            "readonly": 1
        }
    },
    "settings": {
        "log-level": 6,
        "pid-file": "/var/run/pilight.pid",
        "log-file": "/var/log/pilight.log",
        "webserver-enable": 1,
        "webserver-root": "/usr/local/share/pilight/webgui",
        "webserver-http-port": 80,
        "webserver-cache": 1,
        "gpio-platform": "raspberrypi3"
    },
    "hardware": {},
    "registry": {
        "webserver": {
            "ssl": {
                "certificate": {
                    "secure": 0,
                    "location": "/etc/pilight/pilight.pem"
                }
            }
        },
        "pilight": {
            "version": {
                "current": "8.1.2"
            }
        }
    }
}


the rule with == does not work either
 
Reply
#2
Start by reading the forum rules
 
Reply
#3
danke für den hinweis

leider nicht die Lösung oder eine Sinnige Antwort auf mein Problem


thanks for the note

unfortunately not the solution or a sensible answer to my problem
 
Reply
#4
I know, but if you post on this forum we expect you to follow the forum rules. As soon as you did I will answer your questions.

And since this is an English forum, posting in German is of not much use.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Starting pilight on boot: "cannot bind to the SSDP multicast network" pilino1234 3 182 08-31-2019, 10:41 PM
Last Post: curlymo
Tongue pilight 8.1.5-1-gc0a175e0 Chrashes fleisch 4 370 08-17-2019, 01:04 PM
Last Post: curlymo
  pilight for Raspbian Buster (raspberry pi 4) ? starob 29 2,058 07-15-2019, 08:45 PM
Last Post: curlymo
  pilight-receive Filteroption not working Alex 2 472 07-14-2019, 08:35 AM
Last Post: Alex
  pilight usb nano format conversion ettman8 2 360 07-14-2019, 08:32 AM
Last Post: curlymo
  pilight 8.1.4 crashes after some hours Ulrich.Arnold 47 2,370 06-29-2019, 08:58 PM
Last Post: curlymo
  Raspberry PI, gpio-ir-tx and pilight not starting lordslash 5 723 06-11-2019, 05:19 PM
Last Post: curlymo
  pilight fails starting on boot Alex 5 635 06-09-2019, 06:02 PM
Last Post: curlymo
  Google Assistant coupled to pilight hansrijn2 4 1,121 05-29-2019, 06:54 PM
Last Post: curlymo
  pilight-send does not stop (terminate) va13 3 615 05-15-2019, 06:06 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)