• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight-control not able to connect with port and server setting
#1
Since I have installed pilight version v8.1.3-nightly-d2ee2d0d there seems to be an error in pilight-control as this tool is not working anymore.
I always get the error "no pilight ssdp connections found".
The settings for server and port seems to be correct. I can use the pilight-send with these settings and it's working.

For example, this is working:

Code:
pilight-send -S 127.0.0.1 -P 5000 -p intertechno_old -u 15 -i 5 -t


This is not working:

Code:
pilight-control -S 127.0.0.1 -P 5000 -d light_deco_mirror_livingroom -s on
--> pilight-control: NOTICE: no pilight ssdp connections found


The device "light_deco_mirror_livingroom" is of course configured accordingly in config.json.

Any ideas?
 
Reply
#2
I experience no issues:
Code:
# pilight-daemon -V
pilight-daemon version v8.1.3-nightly-d2ee2d0d
# pilight-control -d stalamp1 -s off
# pilight-control -d stalamp1 -s on
 
Reply
#3
(10-18-2018, 05:43 PM)curlymo Wrote: I experience no issues:
Code:
# pilight-daemon -V
pilight-daemon version v8.1.3-nightly-d2ee2d0d
# pilight-control -d stalamp1 -s off
# pilight-control -d stalamp1 -s on

Great, so what can I do?
May be your script behaves different because your configuration is without given IP and port and not as standalone?
 
Reply
#4
(10-20-2018, 07:07 PM)apartmedia Wrote: May be your script behaves different because your configuration is without given IP and port and not as standalone?

What do you mean by this. This is running configuration of the daemon.
Code:
"settings": {
        "log-level": 6,
        "port": 5000,
        "pid-file": "/var/run/pilight.pid",
        "log-file": "/var/log/pilight.log",
        "webserver-enable": 1,
        "webserver-http-port": 80,
        "webserver-cache": 0,
        "stats-enable": 1,
        "gpio-platform": "raspberrypi2",
        "loopback": 0,
        "webgui-websockets": 1,
        "webserver-root": "/media/rpi/daemon/libs/webgui",
        "ntp-servers": [ "0.nl.pool.ntp.org", "1.nl.pool.ntp.org", "2.nl.pool.ntp.org", "3.nl.pool.ntp.org" ],
        "smtp-sender": "xxxxx@xxxxx.com",
        "smtp-host": "smtp.xxxxx.com",
        "smtp-port": 465,
        "smtp-user": "xxxxxx@xxxxx.com",
        "smtp-password": "xxxxx"
    },
 
Reply
#5
As far as I understand this, setting the „standalone“ setting to 1 (which is the case in my config) does make the switches -S and -P mandatory for pilight-control as it disables ssdp. That’s one difference between our configs.
What I don‘t understand if pilight-control breaks with a missing ssdp connection message how can the same pilight-send command work?

This is my settings config:

Code:
"settings": {
 "standalone": 1,
 "port": 5000,
 "log-level": 6,
 "pid-file": "/var/run/pilight.pid",
 "log-file": "/var/log/pilight.log",
 "webserver-enable": 1,
 "webserver-root": "/usr/local/share/pilight/webgui",
 "webserver-http-port": 5001,
 "webserver-cache": 1,
 "gpio-platform": "raspberrypi3",
 "ntp-servers": [ "0.debian.pool.ntp.org", "1.debian.pool.ntp.org", "2.debian.pool.ntp.org", "3.debian.pool.ntp.org" ]
}
 
Reply
#6
The standalone setting disables the SSDP recovery from the daemon to other daemons. Are you sure you only have one daemon running in your network?
 
Reply
#7
I have just one Pi in my network and only this Pi has pilight installed.
When using top and adding a filter for „pilight“ it shows me just one process called „pilight-daemon“.
Killing all pilight processes and restarting the pilight services also not solve the problem.
Rebooting the Pi ends up in same bevavior: One pilight process, missing SSDP connection when using pilight-control.
So I think I can say there is just one pilight-daemon running.

I‘m using pilight-control since my first install of pilight on this Pi.
It worked fine all the time until the update to the latest nightly.

The other question is, if this could be a problem of multiple daemons running on the same network why do I have this error message when using pilight-control and not the same failure when using pilight-send?
How can pilight-send work fine and ignore a missing ssdp connection while pilight-control doesn‘t?
 
Reply
#8
So i've updated your post title. The original title was "pilight-control not working", but as a posted back, it is working fine. 

I now do finally understand what you mean. You have a deamon running in standalone and you are not able to connect with the server / port settings to it.

I you would have elaborated things more completely in the beginning, i would have understood the issue earlier. I will check again.
 
Reply
#9
I‘m sorry for my mistakes and the inconvinience.
The fact that pilight-send worked made me believe that pilight-control is causing the problem and not working correctly.
But you are right, the error message in my initial post is more clearly described with the new title.
Thanx a lot for your support of making this clear and more comprehensible.
 
Reply
#10
I fixed the issue in the latest nightly of tomorrow.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  [Solved] connection to main pilight daemon lost TopdRob 20 3,665 09-17-2017, 04:30 PM
Last Post: curlymo
  homebridge and pilight with scenes ebini 2 1,179 09-16-2017, 10:37 PM
Last Post: apartmedia
  Error compiling pilight development Rolandd 8 2,791 09-10-2017, 12:51 PM
Last Post: tomopxs
  [Solved] pilight nightly not sending codes Cipher 10 2,560 08-24-2017, 09:25 PM
Last Post: curlymo
  pilight not connecting to Webserver Alex 45 7,463 08-04-2017, 12:51 PM
Last Post: Trashware

Forum Jump:


Browsing: 1 Guest(s)