• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
v8.1.3 compile error without https
#1
If I try to compile recent nightly with https disabled, I'll get:

Code:
/usr/local/src/pilight/libs/pilight/lua/lualibrary.c:59:36: error: ‘WEBSERVER_HTTPS’ undeclared here (not in a function)
 { "WEBSERVER_HTTPS", { .number_ = WEBSERVER_HTTPS }, LUA_TBOOLEAN },
                                   ^~~~~~~~~~~~~~~
CMakeFiles/pilight.dir/build.make:2637: die Regel für Ziel „CMakeFiles/pilight.dir/libs/pilight/lua/lualibrary.c.o“ scheiterte
make[2]: *** [CMakeFiles/pilight.dir/libs/pilight/lua/lualibrary.c.o] Fehler 1


With https on, it works..

Regards,
Stefan
 
Reply
#2
Ok, thanks. I will look into it.
 
Reply
#3
Should be fixed.
 
Reply
#4
(10-29-2018, 07:27 AM)curlymo Wrote: Should be fixed.

Nearly... Wink
In lua_c/lualibrary.c this works:


Code:
} pilight_defaults[] = {
        { "PILIGHT_VERSION", { .string_ = PILIGHT_VERSION }, LUA_TSTRING },
        { "PILIGHT_V", { .number_ = PILIGHT_V }, LUA_TNUMBER },
#ifdef WEBSERVER_ENABLE
        { "WEBSERVER_HTTP_PORT", { .number_ = WEBSERVER_HTTP_PORT }, LUA_TNUMBER },
#ifdef WEBSERVER_HTTPS
        { "WEBSERVER_HTTPS_PORT", { .number_ = WEBSERVER_HTTPS_PORT }, LUA_TNUMBER },
#endif
        { "WEBSERVER_ENABLE", { .number_ = WEBSERVER_ENABLE }, LUA_TNUMBER },
#ifdef WEBSERVER_HTTPS
        { "WEBSERVER_HTTPS", { .number_ = WEBSERVER_HTTPS }, LUA_TBOOLEAN },
#endif
#endif

Last #ifdef WEBSERVER_HTTPS .. #endif was missing.

BR,
42
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  rpi3 Buster Compile Error Nikau 4 183 08-18-2019, 09:08 AM
Last Post: curlymo
  ERROR: The Broadcom 2835 GPIO 0 is not set to output mode stuckinger 10 769 05-07-2019, 09:11 PM
Last Post: curlymo
  Assert error in v8.1.3-nightly-d2ee2d0d Ulrich.Arnold 4 504 10-24-2018, 09:28 PM
Last Post: curlymo
  How to compile pilight for your OpenWRT Router frenchie71 4 3,517 11-11-2017, 03:29 PM
Last Post: frenchie71
  [solved] Webgui 404-Error PT-Biker 2 929 11-11-2017, 09:49 AM
Last Post: PT-Biker
  Error installing pilight AMWN 2 1,418 11-02-2017, 10:09 PM
Last Post: AMWN
  Update Error latest Nightly Alex 13 4,028 09-11-2016, 02:51 PM
Last Post: Alex
  [split] pilight Error : pilight hangs in a loop Tommybear1979 5 2,028 07-01-2016, 08:27 AM
Last Post: Tommybear1979
  pilight Error : default_sa_restorer_v2 & CPU High Tommybear1979 5 2,532 06-30-2016, 07:36 AM
Last Post: pilino1234
Bug json get request not working, error in documentation Jan 1 1,611 03-25-2016, 04:12 PM
Last Post: Jan

Forum Jump:


Browsing: 1 Guest(s)