• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight not working with fresh Openhab 2 image
#1
Hi,

after successfully running Openhab 1.x on a Raspberry 3 (incl. pilight to control a lot of 433MHz stuff) for about 2 years w/o ever having to touch anything, in the past month certain things started to fail for me. As according fixes where only produced for Openhab 2 (and I thought about upgrading anyhow for a while already) I decided to setup my Raspberry freshly (no migration) with the latest Openhabianpi full image setup. Everything went smooth so far and I have my old setup pretty much back up & running.
The only thing I can’t get back to work for the life of me is the latest pilight 8.1.4. This was such an easy no-brainer in my old setup that I didn’t even backup any of the old configuration. Now I installed the latest version and it doesn’t fly. I get the somehow famous “NOTICE: no pilight ssdp connections found” error, and while there are tons of troubleshooting guides around (iptables mods, interface cfg. additions etc.), none of them seem to work for me.
I am just hoping this is a special dependency to the Openhabianpi image that someone else already figured out and might give me the final hint.


Here is my config (receive is on GPIO 2/P27 for me – worked just fine before):


Code:
{
   "devices": {},
   "rules": {},
   "gui": {},
   "settings": {
           "log-level": 6,
           "pid-file": "/var/run/pilight.pid",
           "log-file": "/var/log/pilight.log",
           "standalone": 1,
           "webserver-enable": 0,
           "webserver-root": "/usr/local/share/pilight/webgui",
           "webserver-http-port": 5001,
           "webserver-https-port": 5002,
           "webserver-cache": 1,
           "whitelist": "",
           "gpio-platform": "raspberrypi3"
   },
   "hardware": {
           "433gpio": {
                   "sender": 0,
                   "receiver": 2
           }
   },
   "registry": {
           "webserver": {
                   "ssl": {
                           "certificate": {
                                   "location": "/etc/pilight/pilight.pem"
                           }
                   }
           },
           "pilight": {
                   "version": {
                           "current": "8.1.4"
                   }
           }
   }
}

pilight-daemon is not complaining (except about the SSDP issue):


Code:
[Jan 24 13:51:27:263426] pilight-daemon: DEBUG: loaded storage /usr/local/lib/pilight/storage/json/registry.lua v1.0
[Jan 24 13:51:27:273200] pilight-daemon: DEBUG: loaded storage /usr/local/lib/pilight/storage/json/settings.lua v1.0
[Jan 24 13:51:27:283371] pilight-daemon: DEBUG: loaded event function /usr/local/lib/pilight/functions/random.lua v2.1
[Jan 24 13:51:27:284512] pilight-daemon: DEBUG: loaded event function /usr/local/lib/pilight/functions/max.lua v2.1
[Jan 24 13:51:27:285982] pilight-daemon: DEBUG: loaded event function /usr/local/lib/pilight/functions/date_add.lua v2.0
[Jan 24 13:51:27:286952] pilight-daemon: DEBUG: loaded event function /usr/local/lib/pilight/functions/min.lua v2.1
[Jan 24 13:51:27:287970] pilight-daemon: DEBUG: loaded event function /usr/local/lib/pilight/functions/date_format.lua v1.0
[Jan 24 13:51:27:289703] pilight-daemon: DEBUG: loaded event operator /usr/local/lib/pilight/operators/and.lua v1.0
[Jan 24 13:51:27:290671] pilight-daemon: DEBUG: loaded event operator /usr/local/lib/pilight/operators/modulus.lua v1.0
[Jan 24 13:51:27:291404] pilight-daemon: DEBUG: loaded event operator /usr/local/lib/pilight/operators/le.lua v1.0
[Jan 24 13:51:27:291996] pilight-daemon: DEBUG: loaded event operator /usr/local/lib/pilight/operators/concat.lua v1.0
[Jan 24 13:51:27:292918] pilight-daemon: DEBUG: loaded event operator /usr/local/lib/pilight/operators/eq.lua v1.0
[Jan 24 13:51:27:293608] pilight-daemon: DEBUG: loaded event operator /usr/local/lib/pilight/operators/intdivide.lua v1.0
[Jan 24 13:51:27:294249] pilight-daemon: DEBUG: loaded event operator /usr/local/lib/pilight/operators/divide.lua v1.0
[Jan 24 13:51:27:294896] pilight-daemon: DEBUG: loaded event operator /usr/local/lib/pilight/operators/or.lua v1.0
[Jan 24 13:51:27:295536] pilight-daemon: DEBUG: loaded event operator /usr/local/lib/pilight/operators/lt.lua v1.0
[Jan 24 13:51:27:296135] pilight-daemon: DEBUG: loaded event operator /usr/local/lib/pilight/operators/minus.lua v1.0
[Jan 24 13:51:27:296903] pilight-daemon: DEBUG: loaded event operator /usr/local/lib/pilight/operators/gt.lua v1.0
[Jan 24 13:51:27:297610] pilight-daemon: DEBUG: loaded event operator /usr/local/lib/pilight/operators/multiply.lua v1.0
[Jan 24 13:51:27:298314] pilight-daemon: DEBUG: loaded event operator /usr/local/lib/pilight/operators/ge.lua v1.0
[Jan 24 13:51:27:299036] pilight-daemon: DEBUG: loaded event operator /usr/local/lib/pilight/operators/ne.lua v1.0
[Jan 24 13:51:27:299758] pilight-daemon: DEBUG: loaded event operator /usr/local/lib/pilight/operators/plus.lua v1.0
[Jan 24 13:51:27:301172] pilight-daemon: DEBUG: loaded event action /usr/local/lib/pilight/actions/pushover.lua v1.0
[Jan 24 13:51:27:303886] pilight-daemon: DEBUG: loaded event action /usr/local/lib/pilight/actions/switch.lua v4.1
[Jan 24 13:51:27:305623] pilight-daemon: DEBUG: loaded event action /usr/local/lib/pilight/actions/pushbullet.lua v1.0
[Jan 24 13:51:27:307378] pilight-daemon: DEBUG: loaded event action /usr/local/lib/pilight/actions/sendmail.lua v4.1
[Jan 24 13:51:27:310857] pilight-daemon: DEBUG: loaded event action /usr/local/lib/pilight/actions/label.lua v4.1
[Jan 24 13:51:27:312797] pilight-daemon: DEBUG: loaded event action /usr/local/lib/pilight/actions/toggle.lua v4.1
[Jan 24 13:51:27:316735] pilight-daemon: DEBUG: loaded event action /usr/local/lib/pilight/actions/dim.lua v4.1
[Jan 24 13:51:27:322887] pilight-daemon: INFO: version v8.1.4
[Jan 24 13:51:27:346507] pilight-daemon: INFO: daemon listening to port: 35435
[Jan 24 13:51:27:347922] pilight-daemon: DEBUG: new thread socket, 1 thread running
[Jan 24 13:51:27:348070] pilight-daemon: DEBUG: new thread sender, 2 threads running
[Jan 24 13:51:27:348183] pilight-daemon: DEBUG: new thread broadcaster, 3 threads running
[Jan 24 13:51:27:348339] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 57784
[Jan 24 13:51:27:348367] pilight-daemon: DEBUG: client fd: 12
[Jan 24 13:51:27:348393] pilight-daemon: DEBUG: client id: 1
[Jan 24 13:51:27:353991] pilight-daemon: DEBUG: new thread receive parser, 4 threads running
[Jan 24 13:51:27:354218] pilight-daemon: DEBUG: new thread events client, 5 threads running
[Jan 24 13:51:27:354714] pilight-daemon: DEBUG: ssdp sent search
[Jan 24 13:51:27:354958] pilight-daemon: DEBUG: new thread events loop, 6 threads running
[Jan 24 13:51:27:458980] pilight-daemon: NOTICE: no pilight ssdp connections found
[Jan 24 13:51:27:459492] pilight-daemon: INFO: new client, ip: 127.0.0.1, port: 57786
[Jan 24 13:51:27:459536] pilight-daemon: DEBUG: client fd: 15
[Jan 24 13:51:27:459560] pilight-daemon: DEBUG: client id: 2
[Jan 24 13:51:27:459797] pilight-daemon: DEBUG: socket recv: {"action":"identify","options":{"config":1,"receiver":1},"media":"all"}
[Jan 24 13:51:27:459901] pilight-daemon: DEBUG: socket write succeeded: {"status":"success"}

[Jan 24 13:51:27:459963] pilight-daemon: DEBUG: socket write succeeded: {"action":"identify","options":{"config":1,"receiver":1},"media":"all"}

Any information appreciated – I am completely stuck!

Thanks, habitoti
 
Reply
#2
Try setting standalone to 0.
 
Reply
#3
(01-24-2019, 05:41 PM)curlymo Wrote: Try setting standalone to 0.

Wow, wow, wow...

I was just about to write that I tried that already (that was also part of one of the how-tos...) w/o success, but thought I give it another try first, and guess what... ;-)

No clue whether I had all the other thing (iptables etc.) completely in place at that point, but now it works.

Thanks for the instant response!
  habitoti
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
Question Pi 3+ & pilight & 433Mhz RXB6: no receiption hacklschorsch 3 382 02-05-2019, 10:37 PM
Last Post: hacklschorsch
  Consecutive pilight commands habitoti 4 337 01-28-2019, 03:32 PM
Last Post: habitoti
  REST API problem kaku_screen_old / elro_800_switch with pilight 8.1.4 pisperate 4 218 12-20-2018, 09:26 PM
Last Post: pisperate
  pilight v8.0 - Current work in progress curlymo 32 19,327 12-06-2018, 10:06 PM
Last Post: curlymo
  RPI3 b+ Raspbiam Stretch and pilight-7_oregon Tueftler1983 1 240 12-04-2018, 11:59 PM
Last Post: Tueftler1983
  pilight integration in ioBroker Trashware 2 1,185 11-29-2018, 09:14 PM
Last Post: bnk72
  Config migration from pilight 7 .0 to 8.1.3 "Rules" Nonaamee 4 495 11-17-2018, 08:35 PM
Last Post: Nonaamee
  pilight-daemon does not start since 8.1.3-21 robertkrause 1 418 11-05-2018, 07:01 PM
Last Post: robertkrause
Exclamation Brennenstuhl 433MHz RC C1 - pilight not work pitje87 0 379 10-31-2018, 12:38 PM
Last Post: pitje87
  new pilight versions needs new pakets JoeC. 10 2,945 10-16-2018, 05:31 PM
Last Post: Dimi66

Forum Jump:


Browsing: 1 Guest(s)