• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pi 3+ & pilight & 433Mhz RXB6: no receiption
#1
Question 
Hello,
I am trying to receive 433 MHz signals with the following setup:
Raspberry Pi3+
pilight
RXB6 Superheterodyne FHEM receiver

Cabling setup as seen on the attached pictures.

And pilight configuration (see below).

Unfortunately I do not receive anything at all (with pilight-receive) and have no idea whether this due to the electronics setup or software configuration. It would be great if anyone of you has an idea, or maybe just a hint on how to diagnose this better.
BTW I also tried this with a cheap 433MHz receiver that ships everywhere one €bay but not success either. 

Thanks,
hacklschorsch


pilight config:

Code:
root@raspberrypi:~# cat /etc/pilight/config.json

{
    "devices": {},
    "rules": {},
    "gui": {},
    "settings": {
        "log-level": 6,
        "pid-file": "/var/run/pilight.pid",
        "log-file": "/var/log/pilight.log",
        "standalone": 0,
        "webserver-enable": 1,
        "webserver-root": "/usr/local/share/pilight/webgui",
        "webserver-http-port": 5001,
        "webserver-https-port": 5002,
        "webserver-cache": 1,
        "whitelist": "",
        "gpio-platform": "raspberrypi3"
    },
    "hardware": {
        "433gpio": {
            "sender": 0,
            "receiver": 1
        }
    },
    "registry": {
        "webserver": {
            "ssl": {
                "certificate": {
                    "location": "/etc/pilight/pilight.pem"
                }
            }
        },
        "pilight": {
            "version": {
                "current": "8.1.4"
            }
        }
    }
}


Attached Files Thumbnail(s)
           
 
Reply
#2
You've connected the receiver to GPIO 2 not 0.

Also, can you edit your post and start using code tags. Thanks!
 
Reply
#3
Life could be so easy if we do things right... ;-)

Thank you very much!
 
Reply
#4
I would like to ask one more questions:


I have 5 temperature sensors around the house that should be TFA compatible. pilight-daemon -D outputs lots of these messages:

Code:
[Feb 05 21:22:06:172646] pilight-daemon: DEBUG: possible tfa2017 protocol
[Feb 05 21:22:06:172722] pilight-daemon: DEBUG: recevied pulse length of 1624
[Feb 05 21:22:06:172753] pilight-daemon: DEBUG: caught minimum # of repeats 1 of tfa2017
[Feb 05 21:22:06:172783] pilight-daemon: DEBUG: called tfa2017 parseRaw()
[Feb 05 21:22:06:691755] pilight-daemon: DEBUG: possible tfa2017 protocol
[Feb 05 21:22:06:691819] pilight-daemon: DEBUG: recevied pulse length of 11664
[Feb 05 21:22:06:691853] pilight-daemon: DEBUG: caught minimum # of repeats 1 of tfa2017
[Feb 05 21:22:06:691884] pilight-daemon: DEBUG: called tfa2017 parseRaw()

But pilight-receive does not output anything with tfa2017, only from time to time this:

Code:
{
        "message": {
                "id": 0,
                "temperature": -67.77,
                "humidity": 0.00,
                "battery": 1,
                "channel": 1
        },
        "origin": "receiver",
        "protocol": "tfa",
        "uuid": "0000-b8-27-eb-1f80a8",
        "repeats": 1
}

But this could also be from around the neighbourhood. I wonder why aren't the tfa2017 packets shown in pilight-receive?

Thanks again for your help, very appreciated!


Attached Files Thumbnail(s)
   
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight 8.1.4 crashes after some hours Ulrich.Arnold 31 455 13 minutes ago
Last Post: Alex
  Raspberry PI, gpio-ir-tx and pilight not starting lordslash 5 45 06-11-2019, 05:19 PM
Last Post: curlymo
  pilight fails starting on boot Alex 5 114 06-09-2019, 06:02 PM
Last Post: curlymo
  Google Assistant coupled to pilight hansrijn2 4 505 05-29-2019, 06:54 PM
Last Post: curlymo
  pilight-send does not stop (terminate) va13 3 146 05-15-2019, 06:06 PM
Last Post: curlymo
  oom_reaper: reaped process pilight-daemon va13 4 166 05-15-2019, 08:03 AM
Last Post: va13
  cant configure or even start pilight on raspi 3b Xvnx23 2 155 05-06-2019, 09:47 PM
Last Post: fourty2
Sad Raspberry Pi: "NOTICE: no pilight ssdp connections found" abusch 8 238 04-30-2019, 09:10 PM
Last Post: curlymo
  Using pilight-daemon socket API def_meggi 4 149 04-29-2019, 05:58 PM
Last Post: curlymo
  pilight-flash not working danny 9 278 04-27-2019, 09:02 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)