• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pi 3+ & pilight & 433Mhz RXB6: no receiption
#1
Question 
Hello,
I am trying to receive 433 MHz signals with the following setup:
Raspberry Pi3+
pilight
RXB6 Superheterodyne FHEM receiver

Cabling setup as seen on the attached pictures.

And pilight configuration (see below).

Unfortunately I do not receive anything at all (with pilight-receive) and have no idea whether this due to the electronics setup or software configuration. It would be great if anyone of you has an idea, or maybe just a hint on how to diagnose this better.
BTW I also tried this with a cheap 433MHz receiver that ships everywhere one €bay but not success either. 

Thanks,
hacklschorsch


pilight config:

Code:
root@raspberrypi:~# cat /etc/pilight/config.json

{
    "devices": {},
    "rules": {},
    "gui": {},
    "settings": {
        "log-level": 6,
        "pid-file": "/var/run/pilight.pid",
        "log-file": "/var/log/pilight.log",
        "standalone": 0,
        "webserver-enable": 1,
        "webserver-root": "/usr/local/share/pilight/webgui",
        "webserver-http-port": 5001,
        "webserver-https-port": 5002,
        "webserver-cache": 1,
        "whitelist": "",
        "gpio-platform": "raspberrypi3"
    },
    "hardware": {
        "433gpio": {
            "sender": 0,
            "receiver": 1
        }
    },
    "registry": {
        "webserver": {
            "ssl": {
                "certificate": {
                    "location": "/etc/pilight/pilight.pem"
                }
            }
        },
        "pilight": {
            "version": {
                "current": "8.1.4"
            }
        }
    }
}


Attached Files Thumbnail(s)
           
 
Reply
#2
You've connected the receiver to GPIO 2 not 0.

Also, can you edit your post and start using code tags. Thanks!
 
Reply
#3
Life could be so easy if we do things right... ;-)

Thank you very much!
 
Reply
#4
I would like to ask one more questions:


I have 5 temperature sensors around the house that should be TFA compatible. pilight-daemon -D outputs lots of these messages:

Code:
[Feb 05 21:22:06:172646] pilight-daemon: DEBUG: possible tfa2017 protocol
[Feb 05 21:22:06:172722] pilight-daemon: DEBUG: recevied pulse length of 1624
[Feb 05 21:22:06:172753] pilight-daemon: DEBUG: caught minimum # of repeats 1 of tfa2017
[Feb 05 21:22:06:172783] pilight-daemon: DEBUG: called tfa2017 parseRaw()
[Feb 05 21:22:06:691755] pilight-daemon: DEBUG: possible tfa2017 protocol
[Feb 05 21:22:06:691819] pilight-daemon: DEBUG: recevied pulse length of 11664
[Feb 05 21:22:06:691853] pilight-daemon: DEBUG: caught minimum # of repeats 1 of tfa2017
[Feb 05 21:22:06:691884] pilight-daemon: DEBUG: called tfa2017 parseRaw()

But pilight-receive does not output anything with tfa2017, only from time to time this:

Code:
{
        "message": {
                "id": 0,
                "temperature": -67.77,
                "humidity": 0.00,
                "battery": 1,
                "channel": 1
        },
        "origin": "receiver",
        "protocol": "tfa",
        "uuid": "0000-b8-27-eb-1f80a8",
        "repeats": 1
}

But this could also be from around the neighbourhood. I wonder why aren't the tfa2017 packets shown in pilight-receive?

Thanks again for your help, very appreciated!


Attached Files Thumbnail(s)
   
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight switch node in node-red framp 0 112 06-24-2020, 10:01 PM
Last Post: framp
  pilight-control TML 13 693 05-27-2020, 07:51 AM
Last Post: curlymo
  API Requests by HTTP from other devices fore use in pilight scootermacro 2 299 05-10-2020, 08:19 AM
Last Post: scootermacro
  pilight-send seems successful but doesn't actually send RF signal ayeyebrazov 37 2,764 03-31-2020, 01:02 PM
Last Post: curlymo
  pilight 8.1.5 not working on Raspberry pi after reboot beejayf 4 720 03-08-2020, 12:14 AM
Last Post: beejayf
  pilight cpu usage possibly associated with noticeable sluggishness? hepcat72 4 750 01-28-2020, 08:02 PM
Last Post: hepcat72
  apt.pilight.org stable Release' is not signed. thomasol 2 827 01-23-2020, 11:34 PM
Last Post: thomasol
  pilight and SIGNALduino cc1101 Caleus 0 570 01-19-2020, 09:13 AM
Last Post: Caleus
  filter stopped working after update to pilight 8.1.5 zlin50 19 1,807 01-03-2020, 02:15 PM
Last Post: curlymo
Question [Solved] Openweathermap with pilight 7.0-40 doesn't work Seebueb 2 725 01-01-2020, 06:45 PM
Last Post: Seebueb

Forum Jump:


Browsing: 1 Guest(s)