• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ERROR: The Broadcom 2835 GPIO 0 is not set to output mode
#1
Since a recent update from 8.1.4-8-gd702224c to 8.1.4-23-gf6193337 I get the mentioned error when using my 433Mhz module.
The module is connected to a fixed board, so I cannot easily change the used port (wiringpi 1) to test if that helps.
My receiver still works.

After Downgrade to previous version it works again.
Cannot find any helpful hints on the internet or the forum. Any ideas where that comes from?

Message in LOG:

Code:
ERROR: The Broadcom 2835 GPIO 0 is not set to output mode


Installed shown version on raspbian:

Code:
cat /proc/version
Linux version 4.14.98+ (dom@dom-XPS-13-9370) (gcc version 4.9.3 (crosstool-NG crosstool-ng-1.22.0-88-g8460611)) #1200 Tue Feb 12 20:11:02 GMT 2019


On Hardware 1B+

Code:
cat /proc/cpuinfo
processor       : 0
model name      : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS        : 697.95
Features        : half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xb76
CPU revision    : 7
Hardware        : BCM2835
Revision        : 0010
 
Reply
#2
Code tags please.
 
Reply
#3
(03-05-2019, 04:34 PM)stuckinger Wrote: Since a recent update from 8.1.4-8-gd702224c to 8.1.4-23-gf6193337 I get the mentioned error when using my 433Mhz module.
The module is connected to a fixed board, so I cannot easily change the used port (wiringpi 1) to test if that helps.
My receiver still works.

After Downgrade to previous version it works again.
Cannot find any helpful hints on the internet or the forum. Any ideas where that comes from?
Same issue here, just upgraded to latest version and now I get this message. 
Did you solve the problem?
I'm on GPIO 28, Raspberry B1+, which is PIN38
 
Reply
#4
Can you guys post your config?
 
Reply
#5
(04-27-2019, 09:58 AM)curlymo Wrote: Can you guys post your config?

I haven't tried it any more since then...
My pilight config is pretty empty since I only use it on this platform to serve the 433MHz module, controlling with fhem from a different host.

Code:
{
       "devices": {},
       "rules": {},
       "gui": {},
       "settings": {
               "log-level": 6,
               "pid-file": "/var/run/pilight.pid",
               "log-file": "/var/log/pilight.log",
               "port": 5000,
               "webserver-enable": 1,
               "webserver-root": "/usr/local/share/pilight/webgui",
               "webserver-http-port": 5001,
               "webserver-cache": 1,
               "gpio-platform": "raspberrypi1b+"
       },
       "hardware": {
               "433gpio": {
                       "sender": 1,
                       "receiver": 22
               }
       },
       "registry": {
               "webgui": {
                       "tabs": 0
               },
               "webserver": {
                       "ssl": {
                               "certificate": {
                                       "secure": 0,
                                       "location": "/etc/pilight/pilight.pem"
                               }
                       }
               },
               "pilight": {
                       "version": {
                               "current": "8.1.0"
                       }
               }
       }
}
 
Reply
#6
(04-27-2019, 09:58 AM)curlymo Wrote: Can you guys post your config?

Sure!


Code:
{
"devices": {
"kueche": {
"protocol": [ "intertechno_switch" ],
"id": [{
"id": 20648806,
"unit": 0
}],
"state": "off"
}
},
"rules": {},
"gui": {
"kueche": {
"name": "Licht Küche",
"group": [ "MeineSwitches" ],
"media": [ "all" ]
}
},
"settings": {
"log-level": 6,
"pid-file": "/var/run/pilight.pid",
"log-file": "/var/log/pilight.log",
"standalone": 1,
"webserver-enable": 1,
"webserver-root": "/usr/local/share/pilight/webgui",
"webserver-http-port": 5001,
"webserver-https-port": 5002,
"webserver-cache": 1,
"whitelist": "",
"gpio-platform": "raspberrypi1b+"
},
"hardware": {
"433gpio": {
"sender": 28,
"receiver": -1
}
},
"registry": {
"webserver": {
"ssl": {
"certificate": {
"location": "/etc/pilight/pilight.pem"
}
}
},
"pilight": {
"version": {
"current": "8.1.4"
}
}
}
}
Always getting lots of messages when switching on or off:

Code:
[Apr 27 15:08:57:563802] pilight-daemon: ERROR: The Broadcom 2835 GPIO 0 is not set to output mode
 
Reply
#7
one addition: I don't get the "is not set to output mode" message when I set sender GPIO to zero.

Seems like the config parameter is not handled correctly.
 
Reply
#8
Is anyone able to reproduce this behavior?

Just change GPIO Port to something else then 0 and try to send commands. Is it just us or everyone?
 
Reply
#9
Next issue on my list to fix. First the https://forum.pilight.org/showthread.php...8#pid24198
 
Reply
#10
I just found some time for "debugging": I downgraded from version 8.1.4-37-g58e920f7 to 8.0.10 and everything works again. Maybe that will help.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  rpi3 Buster Compile Error Nikau 4 63 08-18-2019, 09:08 AM
Last Post: curlymo
  v8.1.3 compile error without https fourty2 3 420 11-21-2018, 08:02 PM
Last Post: fourty2
  Assert error in v8.1.3-nightly-d2ee2d0d Ulrich.Arnold 4 428 10-24-2018, 09:28 PM
Last Post: curlymo
Bug Bug report: WIFI dongle stops when gpio_switch.gpio = 20 woutput 16 4,793 01-03-2018, 10:11 PM
Last Post: zackdvd
  [solved] Webgui 404-Error PT-Biker 2 850 11-11-2017, 09:49 AM
Last Post: PT-Biker
  Error installing pilight AMWN 2 1,292 11-02-2017, 10:09 PM
Last Post: AMWN
  AdHoc network with 2 Raspberry and 2 GPIO transmitter not working webdandy 29 6,202 09-06-2017, 02:39 PM
Last Post: wseifert
  development, orangepi pc+, "no gpio-platform configured" Twain 1 2,100 06-01-2017, 05:51 PM
Last Post: curlymo
  Relation between raw-output and pulse length TheWheel 9 4,491 12-11-2016, 12:29 PM
Last Post: andies
  Update Error latest Nightly Alex 13 3,858 09-11-2016, 02:51 PM
Last Post: Alex

Forum Jump:


Browsing: 1 Guest(s)