• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
cant configure or even start pilight on raspi 3b
#1
hey there
i am pretty new to rasperry and pilight.
have used the basic coniguration and followed a tutorial which said i should use this config:

      "devices": {},
        "rules": {},
        "gui": {},
        "settings": {
                "log-level": 6,
                "pid-file": "/var/run/pilight.pid",
                "log-file": "/var/log/pilight.log",
                "standalone": 1,
                "webserver-enable": 1,
                "webserver-root": "/usr/local/share/pilight/webgui",
                "webserver-http-port": 11,
                "webserver-https-port": 11,
                "webserver-cache": 1,
                "whitelist": "",
                "gpio-platform": "none"
        },
        "hardware": {},
        "registry": {
                "webserver": {
                        "ssl": {
                                "certificate": {
                                        "location": "/etc/pilight/pilight.pem"
                                }
                        }
                },
                "pilight": {
                        "version": {
                                "current": "8.1.4"
                        }
                }
        }
}


but i cant get the pilight started.
it says:
Job for pilight.service failed because the control process exited with error code.
See "systemctl status pilight.service" and "journalctl -xe" for details.

any suggestions?

the Pi is a model 3b connected with lan to my network
 
Reply
#2
New or not, all users must at least follow the forum rules when posting here. Please fix your post according to them.
 
Reply
#3
(05-06-2019, 07:56 PM)Xvnx23 Wrote:
Code:
                "webserver-http-port": 11,
                "webserver-https-port": 11,

but i cant get the pilight started.
any suggestions?

Ports must be different, eg: 80/http ... 443/https
pilight can't open them "twice".

Stefan
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight switch node in node-red framp 0 112 06-24-2020, 10:01 PM
Last Post: framp
  pilight-control TML 13 693 05-27-2020, 07:51 AM
Last Post: curlymo
  API Requests by HTTP from other devices fore use in pilight scootermacro 2 300 05-10-2020, 08:19 AM
Last Post: scootermacro
  pilight-send seems successful but doesn't actually send RF signal ayeyebrazov 37 2,764 03-31-2020, 01:02 PM
Last Post: curlymo
  pilight 8.1.5 not working on Raspberry pi after reboot beejayf 4 720 03-08-2020, 12:14 AM
Last Post: beejayf
  pilight cpu usage possibly associated with noticeable sluggishness? hepcat72 4 750 01-28-2020, 08:02 PM
Last Post: hepcat72
  apt.pilight.org stable Release' is not signed. thomasol 2 828 01-23-2020, 11:34 PM
Last Post: thomasol
  pilight and SIGNALduino cc1101 Caleus 0 570 01-19-2020, 09:13 AM
Last Post: Caleus
  filter stopped working after update to pilight 8.1.5 zlin50 19 1,808 01-03-2020, 02:15 PM
Last Post: curlymo
Question [Solved] Openweathermap with pilight 7.0-40 doesn't work Seebueb 2 725 01-01-2020, 06:45 PM
Last Post: Seebueb

Forum Jump:


Browsing: 1 Guest(s)