• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Increased CPU usage with version 8.1.5
#1
hi,

after updating from version 8.1.4 to 8.1.5 the CPU usage on my system increased from ~20% to ~35% on average.

parameters:
  • HW: Raspberry Pi 3 Model B Rev 1.2
  • OS: Raspbian 9 / Stretch
  • pilight config: unchanged
  • pilight logs (*.log/*.err): no specific entries.
can someone help?

thanx.
christian.
 
Reply
#2
And why is that an issue?
 
Reply
#3
(08-06-2019, 06:09 PM)curlymo Wrote: And why is that an issue?

because i want to operate my Pi efficiently and have other jobs to run. i do not understand the reason why the usage increases by 15% absolute and 75% relative.
 
Reply
#4
Check the changelog. The hardware modules are now written in lua which makes it easier to expand pilight. But that requires more cpu load.

If you want an efficient setup, you should install a filter. My setup runs at 2% average and 4% cpu usage max. with it.

And still, are you actually experiencing problems with other software that you can relate to pilight directly?
 
Reply
#5
(08-07-2019, 12:33 PM)curlymo Wrote: Check the changelog. The hardware modules are now written in lua which makes it easier to expand pilight. But that requires more cpu load.

If you want an efficient setup, you should install a filter. My setup runs at 2% average and 4% cpu usage max. with it.

And still, are you actually experiencing problems with other software that you can relate to pilight directly?

thanx for the filter hint! are you talking about a SW filter or HW filter?
in case of a SW filter, i know ho to do this for pilight-receive. but how does it work to setup a filter for pilight-daemon?
i did not find this in the documentation.
regarding other SW, there is no interaction problems.
 
Reply
#6
That the whole point I'm trying to make. Let's not make something a theoretical problem when there is no practical one. As long as you aren't experiencing any real issues with the high cpu load then just don't bother.

The filter is the HW filter. Software filtering is already built into pilight.
 
Reply
#7
(08-07-2019, 05:53 PM)curlymo Wrote: That the whole point I'm trying to make. Let's not make something a theoretical problem when there is no practical one.   As long as you aren't experiencing any real issues with the high cpu load then just don't bother.

The filter is the HW filter. Software filtering is already built into pilight.

i highly appreciate pilight as a program and your support, since i know this is a lot of effort. i also accept if - from your perspective & your uses cases - it is not worth to address this specific issue. pefectly fine.  however, it is my personal choice how to operate and optimize my system, i.e. it is a real & practical issue for which i WILL bother.
 
Reply
#8
One of my primary goals is allowing pilight to run fully on a Raspberry Pi 1 (without a HW filter) side by side with Kodi. If that works and the CPU usage is explainable, i'm not adressing it.

Quote:.e. it is a real & practical issue for which i WILL bother.
You said earlier there wasn't.

Quote:regarding other SW, there is no interaction problems.
 
Reply
#9
again, i need to run my system as power-optimized as possible. this is irrespective of interaction with other SW. so, with pilight 8.1.5 my systems consumes significantly more power than before with 8.1.4, therefore this is from my use case point of view a problem and step backwards.
 
Reply
#10
Can you post some numbers?
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  [Fixed] High CPU usage when pilight usb nano disconnects DieterK 1 132 08-13-2019, 05:43 PM
Last Post: curlymo
  High cpu usage Dergo 1 268 02-23-2019, 04:31 PM
Last Post: curlymo
  Wich Version to use Alex 1 867 11-25-2017, 04:32 PM
Last Post: curlymo
  Development Version kniazio 8 3,068 01-23-2017, 12:05 AM
Last Post: wo_rasp
  High cpu usage in 433gpio thread after rpi-update michbeck100 42 19,065 04-23-2015, 08:37 PM
Last Post: thomas.cristo
  webgui/ssh very slow .. high cpu usage gneandr 1 2,423 10-01-2014, 06:43 PM
Last Post: creamers
  [Fixed] usage of log-level rien 3 3,626 05-15-2014, 02:52 PM
Last Post: curlymo
  Development version \ kaku_dimmer Nelus82 2 1,802 03-18-2014, 02:33 PM
Last Post: Nelus82

Forum Jump:


Browsing: 1 Guest(s)