• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Starting pilight on boot: "cannot bind to the SSDP multicast network"
Hi, long time no see!

Currently trying to get pilight working on Debian Buster, but am running into issues with starting pilight on boot.
/var/log/pilight.log shows the following messages at each boot:

(/home/pilight/source/daemon-dev/daemon.c #3082) [Aug 31 12:09:23:655388] INFO: version v8.1.5
(/home/pilight/source/daemon-dev/daemon.c #3151) [Aug 31 12:09:23:764054] INFO: no pilight daemon found, daemonizing
(/home/pilight/source/daemon-dev/libs/pilight/core/socket.c #168) [Aug 31 12:09:23:791098] INFO: daemon listening to port: 5000
(/home/pilight/source/daemon-dev/libs/pilight/core/ssdp.c #119) [Aug 31 12:09:23:791324] ERROR: cannot bind to the ssdp multicast network
(/home/pilight/source/daemon-dev/libs/pilight/core/ssdp.c #302) [Aug 31 12:09:23:800321] ERROR: could not determine default network interface
(/home/pilight/source/daemon-dev/libs/pilight/core/socket.c #577) [Aug 31 12:09:23:801049] INFO: new client, ip:, port: 53048
(/home/pilight/source/daemon-dev/libs/pilight/core/webserver.c #1889) [Aug 31 12:09:23:820631] INFO: secured webserver started on port: 5002 (fd 18) 

Starting pilight manually after bootup works as expected, this specific node is supposed to clientize to a daemon running elsewhere on the network. But the SSDP discovery during bootup fails.

I've tried a bunch of things that worked when this issue occurred often a few years back, including
  • Checking the allowed runlevel and start-requires in the /etc/init.d/pilight file
  • Adding a sleep 5 to /etc/init.d/pilight
  • Adding lo network config in /etc/network/interfaces
  • Setting "wait for network during boot" to true in the raspi-config tool.
So now I'm out of ideas what to try.


Buster 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux

on a raspi 2 (no ipv6 allowed).
Only thing i can think of is letting pilight wait until all network devices are up before trying to use SSDP. I not running buster myself, so also not having any issues.
How would one go about doing that? It's what I've tried to accomplish, both by letting the init.d script sleep, and by checking that network is listed in the start-requires line, but neither of those solutions seem to work.
I meant something inside the pilight codebase that does that. Problem with the whole systemd is that everything has become anoyingly more complex in regard to boot and init.

I'm using a q'n dirty workaround:

root's crontab:
@reboot /home/pi/start_pilight_delay 20

script start_pilight_delay:

sleep $1
sudo /etc/init.d/pilight restart

maybe not fancy... but works.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Real 433Mhz Remote is disturbed by pilight service henne111 2 136 10-06-2019, 06:18 PM
Last Post: wo_rasp
Tongue (solved) pilight 8.1.5-1-gc0a175e0 Chrashes fleisch 5 551 10-03-2019, 01:15 PM
Last Post: fleisch
  pilight for Raspbian Buster (raspberry pi 4) ? starob 29 2,385 07-15-2019, 08:45 PM
Last Post: curlymo
  pilight-receive Filteroption not working Alex 2 556 07-14-2019, 08:35 AM
Last Post: Alex
  pilight usb nano format conversion ettman8 2 441 07-14-2019, 08:32 AM
Last Post: curlymo
  pilight 8.1.4 crashes after some hours Ulrich.Arnold 47 2,652 06-29-2019, 08:58 PM
Last Post: curlymo
  Raspberry PI, gpio-ir-tx and pilight not starting lordslash 5 845 06-11-2019, 05:19 PM
Last Post: curlymo
  pilight fails starting on boot Alex 5 740 06-09-2019, 06:02 PM
Last Post: curlymo
  GPIO input -> starting a rule scootermacro 1 196 06-09-2019, 07:40 AM
Last Post: curlymo
  Google Assistant coupled to pilight hansrijn2 4 1,227 05-29-2019, 06:54 PM
Last Post: curlymo

Forum Jump:

Browsing: 1 Guest(s)