• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight crashing randomly
#1
Hey there,

I am using pilight in combination with FHEM to control my 433 MHz wall plugs. pilight runs on an RPi3B with Raspbian and all updates in place. I am running pilight-daemon version v8.1.5.

Now recently (2-3 month?) it started crashing randomly. About once a week, I would say.

I looked at the pilight.log but only found "new client" entries.
Also the pilight.err log only said "pilight daemon is already running" (probably me trying to start it after a crash) but the timestamps are unrelated to the last crash.

Journalctl gave me only this for the crash timestamp:
Quote:Okt 31 00:33:48 FHEMRasPi systemd[1]: pilight.service: Main process exited, code=killed, status=11/SEGV
Okt 31 00:33:48 FHEMRasPi systemd[1]: pilight.service: Unit entered failed state.
Okt 31 00:33:48 FHEMRasPi systemd[1]: pilight.service: Failed with result 'signal'.

How can I diagnose this furter? A simple restart after the issue occured helps and that's it for another week or so.

Thanks for the help! Smile

Patrick
 
Reply
#2
Did you try the latest nightly?
 
Reply
#3
(10-31-2019, 05:53 PM)curlymo Wrote: Did you try the latest nightly?

Not yet but will do! Smile
Thanks for the hint.
 
Reply
#4
(11-01-2019, 04:36 PM)PatiB Wrote:
(10-31-2019, 05:53 PM)curlymo Wrote: Did you try the latest nightly?

Not yet but will do! Smile
Thanks for the hint.

I tried the nightly and immediately my FHEM was not able to send commands to pilight anymore?
Or somehow it did, the command arrived at pilight, but nothing happened:
Code:
[Nov 16 20:14:48:21231] DEBUG: socket recv: {"action":"send","code":{"protocol":["elro_800_switch"],"systemcode":31,"unitcode":2,"off":1}}
[Nov 16 20:14:48:21402] DEBUG: client disconnected, ip 10.0.0.220, port 49226
[Nov 16 20:14:49:632502] DEBUG: cpu: 0.105229%
[Nov 16 20:14:52:634969] DEBUG: cpu: 0.067633%
[Nov 16 20:14:55:638744] DEBUG: cpu: 0.073755%
[Nov 16 20:14:57:718533] INFO: new client, ip: 10.0.0.220, port: 49230
[Nov 16 20:14:57:718634] DEBUG: client fd: 20
[Nov 16 20:14:57:718699] DEBUG: client id: 4
[Nov 16 20:14:57:718810] DEBUG: socket recv: {"action":"send","code":{"protocol":["elro_800_switch"],"systemcode":31,"unitcode":2,"off":1}}
[Nov 16 20:14:57:718921] DEBUG: client disconnected, ip 10.0.0.220, port 49230

and in FHEM the status of the device did not change.
I uninstalled and reinstalled the stable.
What could've been the reason for this?
 
Reply
#5
I have no clue. Does the latest nightly work on it's own without the use of FHEM?
 
Reply
#6
(11-16-2019, 09:50 PM)curlymo Wrote: I have no clue. Does the latest nightly work on it's own without the use of FHEM?

Stupid question: how can I trigger e.g. the sending of a elro_800 command via terminal (meaning, without FHEM)?
 
Reply
#7
Ok, I found out:
Code:
sudo pilight-send --off -p elro_800_switch -s 31 -u 2 -S 10.0.0.211 -P 5000

although I get a:
Code:
double free or corruption (fasttop)
Abgebrochen
it still works (on stable for now!).
("Abgebrochen" = "Cancelled").


Should I test this on the nightly?
 
Reply
#8
Yes, please test nightly to check if the issue was already fixed.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight cpu usage possibly associated with noticeable sluggishness? hepcat72 4 141 01-28-2020, 08:02 PM
Last Post: hepcat72
  apt.pilight.org stable Release' is not signed. thomasol 2 260 01-23-2020, 11:34 PM
Last Post: thomasol
  pilight and SIGNALduino cc1101 Caleus 0 138 01-19-2020, 09:13 AM
Last Post: Caleus
  filter stopped working after update to pilight 8.1.5 zlin50 19 617 01-03-2020, 02:15 PM
Last Post: curlymo
Question [Solved] Openweathermap with pilight 7.0-40 doesn't work Seebueb 2 162 01-01-2020, 06:45 PM
Last Post: Seebueb
  [Solved] Strange receive problem with 433Mhz Receiver and pilight 8.1.5 vanillaice30 15 794 12-18-2019, 11:09 AM
Last Post: vanillaice30
  pilight error after update to 8.1.5 on Odroid C2 WitchDoctor 3 362 11-29-2019, 09:56 PM
Last Post: curlymo
  [Fixed] RaspberryPi4 pilight 8.1.5 - Send isn't working DominikB1993 4 617 10-18-2019, 10:25 PM
Last Post: DominikB1993
  Real 433Mhz Remote is disturbed by pilight service henne111 2 505 10-06-2019, 06:18 PM
Last Post: wo_rasp
Tongue (solved) pilight 8.1.5-1-gc0a175e0 Chrashes fleisch 5 1,001 10-03-2019, 01:15 PM
Last Post: fleisch

Forum Jump:


Browsing: 1 Guest(s)