• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] Openweathermap with pilight 7.0-40 doesn't work
#1
Question 
For more than two years i became serious ill. I don't have the time and power to spend time for installing new version of pilight and maybe to adjust some configurations. I thought pilight version v7.0-40-gd087b0b works well - but i the meanwhile it seems the openweathermap device is out of order. Means, values do no more change. Neither with update = 1, nor in the webinterface. All my outside christmas lights switches the same time to "on" all the "Advent-Time", regardless to sunset! Can someone (with much higher skill) help. Any advice is appreciated.

Code:
{
 "devices": {
   "zeitunddatum": {
     "protocol": [
       "datetime"
     ],
     "id": [
       {
         "longitude": 9.2038,
         "latitude": 47.5253
       }
     ],
     "year": 2019,
     "month": 12,
     "day": 31,
     "hour": 17,
     "minute": 22,
     "second": 51,
     "weekday": 3,
     "dst": 0
   },
   "outside": {
     "protocol": [
       "openweathermap"
     ],
     "id": [
       {
         "country": "ch",
         "location": "Kradolf"
       }
     ],
     "humidity": 87,
     "temperature": 6.2,
     "sunrise": 7.23,
     "sunset": 16.54,
     "sun": "set",
     "update": 1
   },
   "webcam": {
     "protocol": [
       "generic_webcam"
     ],
     "id": [
       {
         "id": 100
       }
     ],
     "url": "http://www.meteosat.com/imagenes/meteosat/sp/d2-col.jpg"
   }
 },
 "rules": {
   "Alladvent_AutoON": {
     "rule": "IF (outside.sunset == DATE_FORMAT(zeitunddatum, %H.%M)) THEN switch DEVICE alladventonoff TO running AFTER 20 MINUTE",
     "active": 1
   }
 },
 "gui": {
   "zeitunddatum": {
     "name": "Zeit & Datum",
     "group": [
       "Info"
     ],
     "format": "HH:mm:ss   DD-MM-YYYY"
   },
   "outside": {
     "name": "Temperatur",
     "group": [
       "Info"
     ],
     "media": [
       "all"
     ]
   },
   "webcam": {
     "name": "Webcam",
     "group": [
       "Info"
     ]
   }
 }
}
 
Reply
#2
Install the latest version. The openweathermap protocol doesn't work anymore in version 7.
 
Reply
#3
(01-01-2020, 06:30 PM)curlymo Wrote: Install the latest version. The openweathermap protocol doesn't work anymore in version 7.

Bad news - thank you for the fast reply
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight-send seems successful but doesn't actually send RF signal ayeyebrazov 37 1,067 03-31-2020, 01:02 PM
Last Post: curlymo
  pilight 8.1.5 not working on Raspberry pi after reboot beejayf 4 193 03-08-2020, 12:14 AM
Last Post: beejayf
  pilight cpu usage possibly associated with noticeable sluggishness? hepcat72 4 263 01-28-2020, 08:02 PM
Last Post: hepcat72
  apt.pilight.org stable Release' is not signed. thomasol 2 330 01-23-2020, 11:34 PM
Last Post: thomasol
  pilight and SIGNALduino cc1101 Caleus 0 229 01-19-2020, 09:13 AM
Last Post: Caleus
  filter stopped working after update to pilight 8.1.5 zlin50 19 811 01-03-2020, 02:15 PM
Last Post: curlymo
  [Solved] Strange receive problem with 433Mhz Receiver and pilight 8.1.5 vanillaice30 15 979 12-18-2019, 11:09 AM
Last Post: vanillaice30
  pilight error after update to 8.1.5 on Odroid C2 WitchDoctor 3 487 11-29-2019, 09:56 PM
Last Post: curlymo
  pilight crashing randomly PatiB 7 747 11-16-2019, 10:50 PM
Last Post: curlymo
  [Fixed] RaspberryPi4 pilight 8.1.5 - Send isn't working DominikB1993 4 718 10-18-2019, 10:25 PM
Last Post: DominikB1993

Forum Jump:


Browsing: 1 Guest(s)