• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
100% CPU usage
#1
I have been using pilight on my Raspberry Pi 3 for a couple of years without major issues.
A couple of weeks ago I switched the GPIO sender to the USB Nano adapter and everything worked just fine.
(The normal CPU usage on the pi is less than 5%).

But now pilight "builds" an increasing CPU usage over the day until it reaches 100% and pilight it is not responding any more.
If SSH is still possible, stopping and restarting the service gets it running again with little CPU usage, but it only lasts for a 1-2 days until the CPU usage again reaches 100% and I have to restart the pi or the pilight service.
I temporarily used the watchdog setting in the config, but it didn't make any difference.

When the CPU usage was around 40%, the log showed the following message:
Code:
(/home/pilight/source/daemon-dev/libs/pilight/core/eventpool.c #614) [May 18 21:57:07:447622] ERROR: uv_custom_poll_cb: socket not responding

I let the pi running until it was not responding any more and the log showed this:

Code:
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:40:26:824076] cpu usage too high 100.328346%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:40:30:137684] cpu usage too high 100.016646%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:40:33:452735] cpu usage too high 100.013625%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:40:36:767213] cpu usage too high 100.015656%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:40:40:88631] cpu usage too high 100.014245%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:40:43:426592] cpu usage too high 100.013686%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:40:46:764361] cpu usage too high 100.013277%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:40:50:86193] cpu usage too high 100.015402%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:40:53:405344] cpu usage too high 100.013777%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:40:56:726838] cpu usage too high 100.191977%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:41:00:60429] cpu usage too high 100.015294%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:41:03:387339] cpu usage too high 100.014897%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:41:06:720767] cpu usage too high 100.014987%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:41:10:47957] cpu usage too high 100.015527%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:41:13:374578] cpu usage too high 100.014531%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:41:16:714062] cpu usage too high 100.016899%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:41:20:54633] cpu usage too high 100.014140%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:41:23:400799] cpu usage too high 100.014801%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:41:26:733052] cpu usage too high 100.017103%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:41:30:66634] cpu usage too high 100.188392%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:41:33:411990] cpu usage too high 100.015992%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:41:36:745735] cpu usage too high 100.015945%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:41:40:82693] cpu usage too high 100.014899%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 04:41:43:415788] cpu usage too high 100.015199%, will abort when this persists
...
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 07:19:44:800350] cpu usage too high 100.096273%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 07:19:51:447909] cpu usage too high 100.010323%, will abort when this persists
(/home/pilight/source/daemon-dev/daemon.c #2539) [May 19 07:19:58:95062] cpu usage too high 100.010236%, will abort when this persists


My config:

Code:
{
    "devices": {
        "weather": {
            "protocol": [ "tfa" ],
            "id": [{
                "id": 67,
                "channel": 3
            }],
            "temperature": 18.90,
            "humidity": 41.00,
            "battery": 1
        },
        "temperature": {
            "protocol": [ "dht22" ],
            "id": [{
                "gpio": 0
            }],
            "humidity": 0.0,
            "temperature": 0.0,
            "poll-interval": 30
        },
        "Switch1": {
            "protocol": [ "intertechno_old" ],
            "id": [{
                "id": 4,
                "unit": 8
            }],
            "state": "off"
        },
        "Switch2": {
            "protocol": [ "intertechno_old" ],
            "id": [{
                "id": 5,
                "unit": 8
            }],
            "state": "off"
        },
        "Switch3": {
            "protocol": [ "kaku_dimmer" ],
            "id": [{
                "id": 6,
                "unit": 8
            }],
            "state": "off",
            "dimlevel": 15
        },
        "Switch4": {
            "protocol": [ "intertechno_old" ],
            "id": [{
                "id": 0,
                "unit": 8
            }],
            "state": "off"
        },
        "Switch5": {
            "protocol": [ "intertechno_old" ],
            "id": [{
                "id": 1,
                "unit": 8
            }],
            "state": "off"
        },
        "Switch6": {
            "protocol": [ "intertechno_old" ],
            "id": [{
                "id": 0,
                "unit": 2
            }],
            "state": "off"
        },
        "Switch7": {
            "protocol": [ "intertechno_old" ],
            "id": [{
                "id": 1,
                "unit": 2
            }],
            "state": "off"
        },
        "Switch8": {
            "protocol": [ "intertechno_old" ],
            "id": [{
                "id": 2,
                "unit": 2
            }],
            "state": "off"
        },
        "Switch9": {
            "protocol": [ "intertechno_old" ],
            "id": [{
                "id": 3,
                "unit": 2
            }],
            "state": "off"
        }
    },
    "rules": {},
    "gui": {
        "Switch1": {
            "name": "Deckenlicht",
            "group": [ "Licht" ],
            "media": [ "all" ]
        },
        "Switch2": {
            "name": "Esstisch-Lampe",
            "group": [ "Licht" ],
            "media": [ "all" ]
        },
        "Switch3": {
            "name": "Stehlampe",
            "group": [ "Licht" ],
            "media": [ "all" ]
        },
        "Switch4": {
            "name": "Hifi-Steckdose",
            "group": [ "TV-Wand" ],
            "media": [ "all" ]
        },
        "Switch5": {
            "name": "Vitrinenbeleuchtung",
            "group": [ "TV-Wand" ],
            "media": [ "all" ]
        },
        "Switch6": {
            "name": "Kleiderschrank",
            "group": [ "Licht" ],
            "media": [ "all" ]
        },
        "Switch7": {
            "name": "Schlafzimmer",
            "group": [ "Licht" ],
            "media": [ "all" ]
        },
        "temperature": {
            "name": "Wohnzimmersensor",
            "group": [ "Licht" ],
            "media": [ "all" ]
        },
        "weather": {
            "name": "Außensensor",
            "group": [ "Licht" ],
            "media": [ "all" ]
        },
        "Switch8": {
            "name": "Zocki",
            "group": [ "Zocki" ],
            "media": [ "all" ]
        },
        "Switch9": {
            "name": "Baumi",
            "group": [ "Licht" ],
            "media": [ "all" ]
        }
    },
    "settings": {
        "log-level": 6,
        "pid-file": "/var/run/pilight.pid",
        "log-file": "/var/log/pilight.log",
        "webserver-enable": 1,
        "webserver-root": "/usr/local/share/pilight/webgui",
        "webserver-http-port": 81,
        "webserver-https-port": 82,
        "webserver-cache": 1,
        "gpio-platform": "raspberrypi3"
    },
    "hardware": {
        "433nano": {
            "comport": "/dev/ttyUSB0"
        }
    },
    "registry": {}
}

I tried to use a different USB port, different USB cable, different USB Nano, and multiple restart to solve the problem, but without success.
I anyone has an Idea what might cause the high load, please let me know.

Thank you in advance.
 
Reply
#2
Have you tried the latest nightly?
 
Reply
#3
(05-19-2020, 10:08 AM)curlymo Wrote: Have you tried the latest nightly?

Unfortunately I cannot update to the nightly as apt-get update states the following error:

Code:
Paketlisten werden gelesen... Fertig
E: The repository 'h ttp://apt.pilight.org stable Release' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository 'h ttp://apt.pilight.org nightly Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.


I have created a thread named "stable/nightly Release is no longer signed" a few  days ago for this issue.
 
Reply
#4
Should be fixed.
 
Reply
#5
(05-20-2020, 08:32 AM)curlymo Wrote: Should be fixed.

Thank you, it works again!
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  pilight cpu usage possibly associated with noticeable sluggishness? hepcat72 4 714 01-28-2020, 08:02 PM
Last Post: hepcat72
  CPU Usage TomiB 6 1,458 07-11-2019, 08:32 PM
Last Post: curlymo
  pilight-daemon: cpu usage too high when using sendmail bnk72 11 2,747 01-25-2018, 10:00 AM
Last Post: curlymo
Sad cpu usage still too high ... stopping semast0r 6 2,916 05-20-2016, 12:07 AM
Last Post: wo_rasp
  pilight CPU usage reichwar 12 9,014 02-25-2015, 02:23 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)