• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Failed pilight-send that say they succeeded
#1
Recently, my pilight-controlled outlets have started randomly failing to get turned off or on when I issue the pilight-send command and I'm trying to figure out what is going on.  In the past few years of use, I've never seen a command that reported success which failed to change the outlet status.  I have a decent sized antenna that has been 100% reliable for years.  So I took a look at my logs to see if there were any reported failures.

My wrapper for the send command keeps its own log and I checked it out when my instruction to "turn off the bedroom lights" failed on the first attempt (although Siri claimed the outlet was turned off), but succeeded on the second.  Here's what I have:

The failed attempt:
Code:
Sat Dec 5 09:57:45 EST 2020 Turning bedroom lights off
pilight-send -p raw -c "158 592 545 ... 159 5913"

The successful attempt:
Code:
Sat Dec 5 09:57:53 EST 2020 Turning bedroom lights off
pilight-send -p raw -c "158 592 545 ... 159 5913"


Then I took a look at the pilight logs:
Code:
-rw-r--r--  1 root root  43K Dec 17  2019 pilight.err
-rw-r--r--  1 root root  702 Dec  5 09:57 pilight.log
-rw-r--r--  1 root root 2.1K Dec  5 03:00 pilight.log.old


The pilight.err log last showed output about a year ago.  Still, I tailed it in case the date was wrong and indeed, the last error there seems unrelated.  This however is the entirety of the pilight.log file:
Code:
[Dec 05 08:00:02:601445] INFO: version v8.1.5-nightly-c17e1b8e
[Dec 05 08:00:02:709789] INFO: no pilight daemon found, daemonizing
[Dec 05 08:00:02:722391] INFO: daemon listening to port: 41669
[Dec 05 08:00:02:735328] INFO: secured webserver started on port: 5002 (fd 13)
[Dec 05 08:00:02:735432] INFO: regular webserver started on port: 5001 (fd 15)
[Dec 05 08:00:02:737923] INFO: new client, ip: 127.0.0.1, port: 54288
[Dec 05 08:00:02:880024] INFO: new client, ip: 10.0.1.56, port: 45282
[Dec 05 14:54:21:930118] INFO: new client, ip: 10.0.1.56, port: 34932
[Dec 05 14:57:45:650793] INFO: new client, ip: 10.0.1.56, port: 36026
[Dec 05 14:57:53:820542] INFO: new client, ip: 10.0.1.56, port: 36060

The .old log appears to be similar, but it appears I must have some sort of restart of pilight going on at 8am every day:
Code:
[Dec 05 08:00:02:54373] INFO: Interrupt signal received. Please wait while pilight is shutting down
[Dec 05 08:00:02:64815] INFO: removed stale pid_file /var/run/pilight.pid

I don't recall whether I'd set up a recurring 8am restart of pilight or whether that's something pilight does on its own, but otherwise, I don't see a problem with pilight.  I find it curious that there's a "new client" with a different port every so often.  Is that indicative of a problem or a mis-config?

My guess is that pilight however, is behaving as expected.  Do you guys concur?  And if so, could it be that my transmitter chip is going bad or that my antenna connection has gotten loose?
 
Reply
#2
Have you tried a clean OS and a clean pilight installation to start with?
 
Reply
#3
(12-05-2020, 05:23 PM)curlymo Wrote: Have you tried a clean OS and a clean pilight installation to start with?

I figure that unless you suggest that this is likely a software issue, the lowest hanging fruit thing for me to do would be to swap out the transmitter.  (Since I couldn't buy them one at a time, I have like half a dozen unused ones.)  My pi is really overloaded with lots of stuff and I'm honestly a bit scared of what sort of pandora's box a clean OS could create for me.  Besides, I have a new pi 4 in a box that I got for my birthday that I haven't set up yet to replace this overloaded 3B+.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  update pilight Traeumer 0 25 07-29-2021, 09:41 PM
Last Post: Traeumer
  problem publish to pilight MQTT server Emiks5 8 1,561 07-24-2021, 06:46 PM
Last Post: Emiks5
  Hardware Switch and pilight-send/-control iTommix 3 546 02-14-2021, 09:25 PM
Last Post: iTommix
  pilight error after update to 8.1.5 on Odroid C2 WitchDoctor 4 1,719 02-07-2021, 09:50 PM
Last Post: pilightalpine
  pilight in Docker not accepting connections due to possible SYN flooding akloeckner 3 471 02-07-2021, 04:22 PM
Last Post: akloeckner
  pilight-debug format Rschnauzer 2 454 12-17-2020, 07:09 PM
Last Post: Rschnauzer
  pilight-flash not working danny 14 3,383 12-12-2020, 10:00 AM
Last Post: tox
  pilight does not start, Deamon is not found. Dekkertje 6 772 12-08-2020, 06:55 PM
Last Post: Dekkertje
  ERROR: failed to read config. stack: 2 Stefan 7 1,668 11-28-2020, 01:43 PM
Last Post: hannibal-247
  apt.pilight.org/dists/stable/main/binary 301 Moved Permanently Rschnauzer 6 851 11-23-2020, 01:49 PM
Last Post: Rschnauzer

Forum Jump:


Browsing: 1 Guest(s)