• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


[Work in Progress] Rev Ritter
#31
Hi there!
I'm new to pilight..
I have a set of elro switches and rev.

The elro are working great!
For the rev I receive the following in pilight-receive:
Code:
root@pi:~# pilight-receive
{
        "code": {
                "id": "A2",
                "unit": 28,
                "state": "off"
        },
        "origin": "receiver",
        "protocol": "rev_switch",
        "uuid": "03C1-00-00-C1-000300",
        "repeats": 1
}
{
        "code": {
                "id": "A2",
                "unit": 28,
                "state": "off"
        },
        "origin": "receiver",
        "protocol": "rev_switch",
        "uuid": "03C1-00-00-C1-000300",
        "repeats": 2
}
{
        "code": {
                "id": "A2",
                "unit": 28,
                "state": "off"
        },
        "origin": "receiver",
        "protocol": "rev_switch",
        "uuid": "03C1-00-00-C1-000300",
        "repeats": 3
}
{
        "code": {
                "id": "A2",
                "unit": 28,
                "state": "off"
        },
        "origin": "receiver",
        "protocol": "rev_switch",
        "uuid": "03C1-00-00-C1-000300",
        "repeats": 4
}
{
        "code": {
                "id": "A2",
                "unit": 28,
                "state": "off"
        },
        "origin": "receiver",
        "protocol": "rev_switch",
        "uuid": "03C1-00-00-C1-000300",
        "repeats": 5
}
{
        "code": {
                "id": "A2",
                "unit": 28,
                "state": "off"
        },
        "origin": "receiver",
        "protocol": "rev_switch",
        "uuid": "03C1-00-00-C1-000300",
        "repeats": 6
}

But when ever I try to switch the rev switch nothing happens..
The command:
Code:
root@pi:~# pilight-send -p rev_switch -u 28 -i A2 -t
root@pi:~# pilight-send -p rev_switch -u 28 -i A2 -f
root@pi:~# pilight-send -p rev_switch -u 28 -i B1 -t
root@pi:~# pilight-send -p rev_switch -u 28 -i B1 -f
root@pi:~# pilight-send -p rev_switch -u 28 -i F3 -t
root@pi:~# pilight-send -p rev_switch -u 28 -i F3 -f
root@pi:~# pilight-send -p rev_switch -u 28 -i C3 -t
root@pi:~# pilight-send -p rev_switch -u 28 -i C3 -f
The strange thing is, I get no response whatsoever when I use pilight-daemon or pilight-learn...

Any ideas?

// added code tags
 
Reply
#32
Can you post pilight-debug info for all buttons?
 
Reply
#33
As I posted above, I don't get any output..

I press the button long (10sec) or short - twice, different order also rebooted a couple of times..

I try again tomorrow, but I still think I won't get any different results..
 
Reply
#34
Can you post some pilight-raw output on pastebin?
 
Reply
#35
Here:

http://paste.debian.net/85155/
 
Reply
#36
Are you sure the rev output is actually rev and not random noise interpreted as rev?
 
Reply
#37
Yes, I left it on a while, and there where no "incoming" signals, when I press a button it directly responses.
 
Reply
#38
It's wierd that pilight-debug doesn't work then. I also don't see usefull info in the pilight-raw output.
 
Reply
#39
hello ! i can switch my rev switches succesfully !

A1 = -i F7 -u 0
A2 = -i E7 -u 0
A3 = -i D7 -u 0

but what is the id fpr B2 or C2 ?

i habe tested a lot of codes, can someone help pls !?
 
Reply
#40
You can help by providing pilight-debug info.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Smartwares switch SH5-RBU-04A and SH5-RBS-04A doesn't work with 8.0.3 flying_dutchman 51 13,120 05-22-2019, 11:16 AM
Last Post: bitboy
  [Work in progress] somfy controller sandoz 128 48,031 05-06-2017, 10:38 AM
Last Post: wo_rasp

Forum Jump:


Browsing: 1 Guest(s)