• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


eHome Switches
#11
I tried a little bit more:

I think the first two numbers are the on and off signals:

283 849 -> ON
849 283 -> OFF

Then the binary code starts:

283 849 283 849 -> 1
849 283 283 849 -> 0

The last three parts are always the same:

283 283 9622

So i think this is the housecode. The housecode can be defined by three dip switches. 283 283 9622 must be OFF, OFF, OFF. I don't know how the 9622 is definded?? Replacing one 283 with 849 like 849 283 9622 doesn't work with ON OFF OFF.

The raw codes posted by ligi are a bit strange, because there a numbers like 284, 852, 282, 846 and so on, but if i replace them with 283 and 849 all units still work .

EDIT: Hmmm, the binary code is one number too long for my theory.

The last four raw codes

849 283 283 9622

don't fit :-(
 
Reply
#12
@ligi
Could you post the output of the plugs with the housecode (first 3 DIP) set to something like "ON OFF OFF" or "ON ON OFF" ?

I own 16 switches and can only use 4, because the code isn't decrypted yet :-/

This would help developing a plugin for these switches :-)

(04-14-2014, 07:59 PM)holybabel Wrote: Ok, found out that there must be a difference between units with other ids.

I have 5 units with S/N 050701 which work perfect and 3 units with S/N 050501 which aren't working at all with this codes.

mine are working with these codes! Except one..still need morge debug data, to figure out the protocol...
 
Reply
#13
I've just added support for these switches. Can you guys test?
 
Reply
#14
Hi curlymo,

i've updated to the new pilight version throught apt. Which protocol do i have to use now?

EDIT: Ok, i have to use the development branch. I will install and try.

EDIT2: I get an error message:

Code:
CMake Error at CMakeLists.txt:225 (if):
  if given arguments:

    "ON" "BOOL" "support for the eHome switch protocol" "MATCHES" "OFF"

  Unknown arguments specified


-- Configuring incomplete, errors occurred!
make: *** No rule to make target `install'.  Stop.

Greetings holybabel
 
Reply
#15
Fixed
 
Reply
#16
Wow...ultra fast :-)

Development-branch is installing. I will try...

Ok, what arguments do i have to use?
 
Reply
#17
First test the receiving then sending:
Code:
pilight-send -p ehome -i 1 -t
 
Reply
#18
Hi curlymo,

i can't try the receiving, because i don't have a remote.

I will try the sending method.

Gesendet von meinem Q5 mit Tapatalk
 
Reply
#19
Hm, doesn't work for me.

I have dip 1-3 off and the switch doesn't turn on. Tried all four possibilities.
 
Reply
#20
Then i do need some pilight-debug info.
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Unitec Switches rien-ne-va-plus 48 35,002 05-29-2019, 02:16 PM
Last Post: bitboy
  RSL366T Switches juri 60 32,741 05-24-2018, 06:48 PM
Last Post: bobg
  [Fully Supported] Clarus Switches Marcin 69 32,553 01-30-2018, 07:10 PM
Last Post: Niek
  Unitec / Intertek Switches dieterhatn 1 1,526 03-07-2017, 07:04 PM
Last Post: pilino1234
  CLOSED: Unbranded White Programmable plug-in wall switches alasdairc 8 3,494 11-13-2016, 11:47 PM
Last Post: alasdairc
Brick Aukey Switches VrahoK 5 2,464 11-01-2016, 06:56 AM
Last Post: curlymo
  DBPower Switches joaoasilva 5 3,665 09-25-2014, 08:45 PM
Last Post: joaoasilva
  Support for Schwaiger/Goobay switches plinden 10 6,979 05-16-2014, 11:20 PM
Last Post: curlymo

Forum Jump:


Browsing: 1 Guest(s)