• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
pilight 3.0
#21
FYI, after pulling the latest commit tonight, I had to change my hardware.json.

Old:
Code:
{
    "433gpio": {
        "sender": 1,
        "receiver": 0
    }
}

New:
Code:
{
    "433gpio": {
        "sender": 0,
        "receiver": 1
    }
}
 
Reply
#22
@hawkeyexp, you see! Good job. A little patience and investigation will help yourself AND others! Thx!


(02-16-2014, 04:21 PM)hawkeyexp Wrote: during typing i tried something out: i changed the pins from sender and receiver and it WORKS ?? WTF ?

pilight2.1: sender 2 / receiver 13
pilight3: sender 13 / receiver 2

Seems there is a bug in code of v3 and sender and receiver are swapped ?
 
Reply
#23
@vangod, in the upper right corner it says: 'Toggle Panel'. There you can choose 'View unread posts' and read up on posts and keep track of changes / discussions etc.

Little hint.
 
Reply
#24
I just installed, every time I "systemctl restart pilight" (I use Arch Linux) my /etc/pilight/pilight.json (my config file) is emptied... I just wanted to see if it worked and added:

Code:
{
    "living": {
        "name": "Living"
    },
    "bedroom": {
        "name": "Bedroom"
    }      
}

Form the example. Nothing shows up in the web interface. It is difficult to play with parameters if the config file is emptied everytime, is this normal? Perhaps I forgot to read something...
 
Reply
#25
(03-02-2014, 10:24 PM)freek Wrote: I just installed, every time I "systemctl restart pilight" (I use Arch Linux) my /etc/pilight/pilight.json (my config file) is emptied...

Try stopping and starting the service instead of restarting pilight. That works better for me (on raspbian).
 
Reply
#26
Restarting is essentially just stopping and starting in one command.
 
Reply
#27
try first to stop your service, edit the file, start the service

Send from tapatalk phone...
 
Reply
#28
Hi,

Running pilight 3.0 on raspberry v2. 433 Mhz sender and receiver are: RXB6 and KXD 10036. Like adviced in your link.

Receiving works flacky. You can see with pilight-raw a lot of data is received. However it is possible to here and there receive good codes with pilight-dump.

Sending is fine.

Also webinterface works fine. Nice that is is built up with the json input.

I have no filter installed this might explain why receive still gives trouble. Before i start to install a filter i would like to ask if it is possible to work with pilight.ko already. I tried the 3.10.25+ but i don't see it with lsmod after modprobe.
 
Reply
#29
Kernel module development has halted.

There is no such thing as pilight-dump?
 
Reply
#30
Oh, i meant pilight-debug Wink
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  problem publish to pilight MQTT server Emiks5 4 301 08-31-2020, 07:45 PM
Last Post: Emiks5
  pilight for Raspbian Buster (raspberry pi 4) ? starob 32 8,950 08-10-2020, 09:12 AM
Last Post: simanuel
  pilight switch node in node-red framp 0 393 06-24-2020, 10:01 PM
Last Post: framp
  pilight-control TML 13 1,322 05-27-2020, 07:51 AM
Last Post: curlymo
  API Requests by HTTP from other devices fore use in pilight scootermacro 2 630 05-10-2020, 08:19 AM
Last Post: scootermacro
  pilight-send seems successful but doesn't actually send RF signal ayeyebrazov 37 3,998 03-31-2020, 01:02 PM
Last Post: curlymo
  pilight 8.1.5 not working on Raspberry pi after reboot beejayf 4 1,096 03-08-2020, 12:14 AM
Last Post: beejayf
  pilight cpu usage possibly associated with noticeable sluggishness? hepcat72 4 1,164 01-28-2020, 08:02 PM
Last Post: hepcat72
  apt.pilight.org stable Release' is not signed. thomasol 2 1,276 01-23-2020, 11:34 PM
Last Post: thomasol
  pilight and SIGNALduino cc1101 Caleus 0 847 01-19-2020, 09:13 AM
Last Post: Caleus

Forum Jump:


Browsing: 1 Guest(s)