• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] No ssdp connection found
i have only one raspberry Pi running,
and only one pilight service instance (as far as I know).
so i do not quite understand what you mean
Ah, ok. That explains it too Smile So this isn't really a bug for you if you're only running one pilight instance; it's an issue with larger systems of several pilight nodes that are supposed to communicate. You can read more about it in detail here

So you don't need to worry about this, the message is simply because there are no other pilight instances running in your network, so the pilight-daemon does not find any others when it searches for them.
OK thanx
so if i run pilight-receive, that message is also displayed because no other daemons are found?
Not quite: pilight-receive needs a pilight-daemon running (can be on the same computer or a different one on the same network) to work.
So you need to start the pilight daemon and when it's running, then you can start pilight-receive.
This is what I found after quite too long experimenting and re-installing:

In a fresh install on NOOBS (that's for me) 'pilight-send bla bla' works fine.
After I configure config.json with all sorts of info, including '"standalone": 1' (don't mind the rest of the world) in the settings section, and having it play ball, my commandline 'pilight-send' throws me the ssdp message. Changing '"standalone": 0' or removing it, makes no difference. ('service pilight stop' - alter config.json - 'service pilight start')

But if I replace config.json with the bare OOTB version 'pilight-send' works fine again.

So apparantly I cann't have the command line and the server working at the same time. I do not actually need them both, so I made a shell script to backup config.json and copy config.json-default and vice versa for when I do need to switch.

I hope it saves at least one person a lot of time...
What is the exact command you try to use?

If "standalone = 1" you always have to declare server and port in your commands so the deamon can be found.

What port do you use in your config? (not webserver-http-port).
Here you find more Informations: Manual
Also try pilight-receive -H for more informations.
Terrarium:  RPi Model B Rev 2 / pilight 8.1.2 / stretch
Aquarium: RPi Model B Plus Rev 1.2 / pilight 8.0.6 / jessie

The exact command I use (with some variations) is 'pilight-send -p kaku_switch_old -i 23 -u 4 -t'
I used this setting in config.json in the settings section: "port": 5000
left it as it was.

I think I did a good job reading the manual, which is a little short in explanations, taking quite some knowledge for granted, but I figured out most things I think I need up to now. Remember; the NOOBS level also applies to pilight for me. So thanks for helping me out, or at least thinking about it :-)

The next step will be to get it to run some schema's, hopefully with a little random included and some sun set and sun rise info, so I can kick out all the various time swicthes in my home. Very pleased to have stumbled upon pilight!

(11-23-2015, 10:31 PM)terrar Wrote: What is the exact command you try to use?

If "standalone = 1" you always have to declare server and port in your commands so the deamon can be found.

What port do you use in your config? (not webserver-http-port).
Here you find more Informations: Manual
Also try pilight-receive -H for more informations.
In this thread and in the FAQ
sudo iptables -A INPUT -s -j ACCEPT
is mentioned as an important setting.
At least on my system running on Raspbian Jessie this setting is just kept in memory and therefore gone after a reboot.
(just run
sudo iptables -L
to see the difference before and after reboot).
To make it permanent I used the iptables-persistent package.
sudo apt-get install iptables-persistent
sudo iptables -A INPUT -s -j ACCEPT
sudo bash -c "iptables-save > /etc/iptables/rules.v4"

Some of my iptables rules seems to be set by other ways and I end up with several identical rules twice in iptables (once by whatever way and once by /etc/iptables/rules.v4 ). As a non expert I think this should not harm having the same rule several times but to to make sure that I don't get inconsistencies if I change one of them later I removed the other ones out of /etc/iptables/rules.v4 .

I'm still having problems with SSDP errors but nervelessness I think I made a step in the right direction. Now I'll see what else could be the problem....
I solved this by adding "$local_fs $network" to the pilight init script
Now no manual restart is needed after a reboot.

nano /etc/init.d/pilight

#! /bin/sh
# Provides: pilight-daemon
# Required-Start: $local_fs $network $remote_fs $syslog
# Required-Stop: $remote_fs $syslog

After editing run:
update-rc.d pilight defaults
iam always getting the error "no pilight ssdp connections found"

was searching for a solution for hours... also the last post didnt help.

what can i do do solve this issiue?

Possibly Related Threads...
Thread Author Replies Views Last Post
  [Solved] pilight service crashing on first webserver access after reboot VrahoK 20 4,976 12-21-2019, 09:46 AM
Last Post: curlymo
  Connection lost, trying to reconnect — loop apartmedia 5 2,173 03-16-2019, 09:41 AM
Last Post: curlymo
  [solved] Webgui 404-Error PT-Biker 2 2,131 11-11-2017, 09:49 AM
Last Post: PT-Biker
  [solved] Hardware not compatible ccc.ggg73 1 2,333 06-10-2017, 09:10 AM
Last Post: curlymo
  Standalone but SSDP brenner23 6 4,156 04-16-2017, 11:34 PM
Last Post: brenner23
  [Solved] pilight ssdp celle 6 10,410 02-23-2017, 03:22 PM
Last Post: gneandr
  Raspbian jessie - pilight 7 - no pilight ssdp connections found shirocko 20 22,796 01-29-2017, 10:23 PM
Last Post: gneandr
  [solved] No signal with raw data andies 6 4,815 12-25-2016, 09:11 AM
Last Post: andies
  pilight without internet connection terrar 5 4,956 08-12-2016, 09:47 PM
Last Post: terrar
  ssdp discovery clach04 5 6,699 05-23-2016, 04:23 PM
Last Post: pilino1234

Forum Jump:

Browsing: 1 Guest(s)