• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] No ssdp connection found
I dont kwno what to do, pilight issnt working.

I have done the update and the firmware update on den pi B+

pilight-send gives me alwasy the following error:
pilight-send: NOTICE: no pilight ssdp connections found

pilight-debug gives me this output:
[Jun 10 07:27:54:505233] pilight-debug: ERROR: hardware not supported
[Jun 10 07:27:54:507914] pilight-debug: ERROR: could not initialize 433gpio hardware mode

Please help me, it would be great if pilight works again
This question has been asked at least 10 times before. Please search the forum.
thank you for your answer

i have searched the forum, i am trying to solve the problem for over a week now. nothing works.


it works now.

sudo apt-get install pilight=7.0.8-g953bb85
sudo rpi-update 52241088c1da59a359110d39c1875cda56496764

+ deleting the https port out of config.json
Today I ran
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

It proposed that pilight is going to be updated. I thought it was a good idea.
However, from now on pilight is no longer working!!!
At first /var/log/pilight.err said: No ssdp connection found

I then tried:
sudo apt-get install pilight=7.0.8-g953bb85
pilight-debug says:
pilight-debug: ERROR: hardware not supported
pilight-debug: ERROR: could not initialize 433gpio hardware mode

When going back to newest installation (sudo apt-get install pilight --- since today pilight (7.0.194-gadc4c79) ) pilight-debug says:
pilight-debug: ERROR: no gpio-platform configured
pilight-debug: ERROR: could not initialize 433gpio hardware mode
These are also the latest comments in /var/log/pilight.err

I dont know which (running) version i had installed previously. I firstly installed pilight in April/May 2017.
Could you please help me! Do you have any ideas, what is broken now?
I solved it - it was pretty easy, when you know, what you are doing:

insert in /etc/pilight/config.json settings:
"gpio-platform": "raspberrypi3"
and it worked!

Running the following version sucessfully:
pilight-daemon version v7.0-194-gadc4c79
Linux raspberrypi 4.9.34-v7+ #1013 SMP Sun Jun 25 17:06:40 BST 2017 armv7l GNU/Linux

With the previous version (v7.0-184-ga40f146), I did not need the gpio-platform!

I also got a problem here. Everytime I reboot my RPi2 pilight doesn´t work until I restart the pilight service manually.
I´ve already searched google and this forum but I cannot find any solutions that works.
But here some facts:
- I use volumio as distribution
- wlan connection
- kernel: Linux volumio 4.4.9-v7+ #884

service info after reboot:

pilight.service - LSB: Starts pilight-daemon
   Loaded: loaded (/etc/init.d/pilight)
  Drop-In: /etc/systemd/system/pilight.service.d
   Active: active (exited) since Thu 2017-07-27 18:39:06 UTC; 43min ago
  Process: 766 ExecStart=/etc/init.d/pilight start (code=exited, status=0/SUCCESS)

Jul 27 18:39:04 volumio systemd[1]: Starting LSB: Starts pilight-daemon...
Jul 27 18:39:06 volumio pilight[766]: Starting : pilight.
Jul 27 18:39:06 volumio systemd[1]: Started LSB: Starts pilight-daemon.

Warning: Unit file changed on disk, 'systemctl daemon-reload' recommended.

I have already tried systemctl daemon-reload but it shows the message every reboot again.

pilight log after reboot:

volumio@volumio:~$ cat /var/log/pilight.log
[  Jul 27 17:23:54:7401] pilight-daemon: INFO: rule #1 fernbd1-on1 was parsed in 0.000593 seconds
[  Jul 27 17:23:54:7935] pilight-daemon: INFO: rule #2 fernbd1-on2 was parsed in 0.000451 seconds
[  Jul 27 17:23:54:8410] pilight-daemon: INFO: rule #3 fernbd1-off1 was parsed in 0.000431 seconds
[  Jul 27 17:23:54:8922] pilight-daemon: INFO: rule #4 fernbd1-off2 was parsed in 0.000468 seconds
[  Jul 27 17:23:54:9433] pilight-daemon: INFO: rule #5 fernbd2-on1 was parsed in 0.000455 seconds
[  Jul 27 17:23:54:9962] pilight-daemon: INFO: rule #6 fernbd2-on2 was parsed in 0.000481 seconds
[ Jul 27 17:23:54:10436] pilight-daemon: INFO: rule #7 fernbd2-off1 was parsed in 0.000426 seconds
[ Jul 27 17:23:54:10910] pilight-daemon: INFO: rule #8 fernbd2-off2 was parsed in 0.000430 seconds
[ Jul 27 17:23:54:11375] pilight-daemon: INFO: rule #9 fernbd3-on1 was parsed in 0.000425 seconds
[ Jul 27 17:23:54:11836] pilight-daemon: INFO: rule #10 fernbd3-on2 was parsed in 0.000420 seconds
[ Jul 27 17:23:54:12315] pilight-daemon: INFO: rule #11 fernbd3-off1 was parsed in 0.000438 seconds
[ Jul 27 17:23:54:12785] pilight-daemon: INFO: rule #12 fernbd3-off2 was parsed in 0.000430 seconds
[ Jul 27 17:23:54:15886] pilight-daemon: INFO: version v7.0-198-g1c5c59b
[Jul 27 17:23:54:113586] pilight-daemon: INFO: no pilight daemon found, daemonizing
[Jul 27 17:23:54:114589] pilight-daemon: INFO: daemon listening to port: 42624
[Jul 27 17:23:54:114710] pilight-daemon: ERROR: cannot bind to the ssdp multicast network
[Jul 27 17:23:54:149294] pilight-daemon: INFO: new client, ip:, port: 52486

volumio@volumio:~$ dpkg -s pilight
Package: pilight
Status: install ok installed
Priority: optional
Section: utils
Installed-Size: 22973
Maintainer: CurlyMo <info@pilight.org>
Architecture: armhf
Version: 7.0.198-g1c5c59b

volumio@volumio:~$ cat /etc/network/interfaces
auto lo
auto wlan0
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet dhcp

I´ve already tried to change the configuration with some hints from the forums, but without success.

Modifications of startup scripts:

volumio@volumio:~$ cat /etc/init.d/pilight
#! /bin/sh
# Provides:          pilight-daemon
# Required-Start:    $network $named $remote_fs $syslog
# Required-Stop:     $remote_fs $syslog
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Starts pilight-daemon
# Description:       Starts pilight-daemon

volumio@volumio:~$ cat /etc/systemd/system/pilight.service.d/pilight.conf
Requires = network-online.target
After = network-online.target

Current Config: https://pastebin.com/b68LgzPc

Before I tried the latest pilight stable. It didn’t work there, so I upgraded to the nightly, which didn’t help. Only difference: Now the webui does not load anymore. Did anything change there?

So my questions are:
1) How can I fix the startup to work like expected?
2) How can I fix the web UI?

Many thanks in advance!


can someone say when it is planned to fix this problem in the stable release of pilight, so that it will work with the current raspberry kernel 4.9?

Thank you
If the rewrite is going to take a lot longer we could do a 7.1 release that fixes this I suppose (or 7.0.1 in semver) @curlymo
A release with just the wiringx fixes is a good idea.

i installed pilight on my Raspberry Pi Zero W after using Noobs to install Raspbian.

Unfortunately, i am also experiencing getting "pilight-receive: NOTICE: no pilight ssdp connections found"

This is what i tried, after starting pilight with "sudo service pilight start":

1. I added this to /etc/network/interfaces

Quote:allow-hotplug wlan0
iface lo inet loopback
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

Is this right? Because my RPi Zero W is connected via Wifi i tried this... But i'm not sure if the entries are right. I'm still a beginner regarding the pi...

2. sudo iptables -A INPUT -s -j ACCEPT
--> no success

3. added "standalone": 1 to etc/pilight/config.json
--> no success

I didn't read the whole thread yet, but will do it tomorrow...
Does anybody know what to do now? Is there something special about the pi zero w?

Thanks in advance!!

Possibly Related Threads...
Thread Author Replies Views Last Post
  [Solved] pilight service crashing on first webserver access after reboot VrahoK 20 6,560 12-21-2019, 09:46 AM
Last Post: curlymo
  Connection lost, trying to reconnect — loop apartmedia 5 2,786 03-16-2019, 09:41 AM
Last Post: curlymo
  [solved] Webgui 404-Error PT-Biker 2 2,884 11-11-2017, 09:49 AM
Last Post: PT-Biker
  [solved] Hardware not compatible ccc.ggg73 1 2,760 06-10-2017, 09:10 AM
Last Post: curlymo
  Standalone but SSDP brenner23 6 4,859 04-16-2017, 11:34 PM
Last Post: brenner23
  [Solved] pilight ssdp celle 6 11,228 02-23-2017, 03:22 PM
Last Post: gneandr
  Raspbian jessie - pilight 7 - no pilight ssdp connections found shirocko 20 25,180 01-29-2017, 10:23 PM
Last Post: gneandr
  [solved] No signal with raw data andies 6 5,488 12-25-2016, 09:11 AM
Last Post: andies
  pilight without internet connection terrar 5 6,088 08-12-2016, 09:47 PM
Last Post: terrar
  ssdp discovery clach04 5 7,443 05-23-2016, 04:23 PM
Last Post: pilino1234

Forum Jump:

Browsing: 1 Guest(s)