• 10 dec 2017: forum version update. In case of issues use this topic.
  • 30 nov 2017: pilight moved servers. In case of issues use this topic.
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] No ssdp connection found
#11
For "lsb_release" you have to install it via "apt-get install lsb_release"
 
Reply
#12
it's "apt-get install lab-release" and not "apt-get install lsb_release"
 
Reply
#13
worked like a charm Smile

No error when starting for a second time:

Code:
pi@raspberrypi ~ $ sudo apt-get install lsb-release
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  lsb
The following NEW packages will be installed:
  lsb-release
0 upgraded, 1 newly installed, 0 to remove and 72 not upgraded.
Need to get 27.1 kB of archives.
After this operation, 105 kB of additional disk space will be used.
Get:1 http://mirrordirector.raspbian.org/raspbian/ wheezy/main lsb-release all 4.1+Debian8+rpi1 [27.1 kB]
Fetched 27.1 kB in 0s (59.0 kB/s)
Selecting previously unselected package lsb-release.
(Reading database ... 66487 files and directories currently installed.)
Unpacking lsb-release (from .../lsb-release_4.1+Debian8+rpi1_all.deb) ...
Processing triggers for man-db ...
Setting up lsb-release (4.1+Debian8+rpi1) ...
pi@raspberrypi ~ $ sudo service pilight start
[ ok ] pilight is running.
pi@raspberrypi ~ $ sudo service pilight stop
[ ok ] Stopping : pilight.
pi@raspberrypi ~ $ sudo service pilight start
[ ok ] Starting : pilight.
pi@raspberrypi ~ $ sudo service pilight stop
[ ok ] Stopping : pilight.
pi@raspberrypi ~ $ sudo service pilight start
[ ok ] Starting : pilight.
pi@raspberrypi ~ $
 
Reply
#14
Hi all!

After a while I've decided to format my raspi and start from 0 with a clean sd img. And I think that I've followed all the steps but now I can't run my pilight.

For example:

When I try pilight-receive:
Code:
[Mar 16 20:50:22:612556] pilight-receive: ERROR: no pilight ssdp connections found
[Mar 16 20:50:22:629566] pilight-receive: DEBUG: garbage collected log library

I've try to find out in the wiki/forum/web/google without results

pilight-raw looks work fine

webui works but doesn't send or receive data.

hardware.json

Code:
{
        "433gpio": {
                "sender": 0,
                "receiver": 1
        }
}

settings.json

Code:
{
        "log-level": 4,
        "pid-file": "/var/run/pilight.pid",
        "config-file": "/etc/pilight/config.json",
        "hardware-file": "/etc/pilight/hardware.json",
        "log-file": "/var/log/pilight.log",
        "send-repeats": 10,
        "receive-repeats": 1,
        "webserver-enable": 1,
        "webserver-root": "/usr/local/share/pilight",
        "webserver-port": 5001,
        "webserver-cache": 1,
        "webserver-authentication": 0,
        "webserver-username": "",
        "webserver-password": "",
        "whitelist": "",
        "update-check": 1,
        "standalone": 1
}

config.json

Code:
{
        "lobby": {
                "name": "Entrada",
                "switchb": {
                        "name": "Lampara",
                        "protocol": [ "elro_hc" ],
                        "id": [{
                                "systemcode": 0,
                                "unitcode": 23
                        }],
                        "state": "off"
                }
        }
}

pilight-daemon -V
pilight-daemon version 3.0, commit v3.0

Thanks!
 
Reply
#15
How did you install, manually compiling or apt?
 
Reply
#16
Manually from git


Enviado desde mi iPad con Tapatalk
 
Reply
#17
Does pilight-daemon run ok?
 
Reply
#18
I think so. The service starts without problems and web server too but if I make a switch change in web (0 to 1) and then refresh F5, switch keep 0 instead 1 and in some cases web server goes down.

How can i cheek the daemon run?
 
Reply
#19
By starting in debug mode and watching what happens.
 
Reply
#20
Sorry but... How can I execute pilight in debug mode? Need to install debug in protocol list?
 
Reply
  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Connection lost, trying to reconnect — loop apartmedia 5 431 03-16-2019, 09:41 AM
Last Post: curlymo
  [solved] Webgui 404-Error PT-Biker 2 857 11-11-2017, 09:49 AM
Last Post: PT-Biker
  [solved] Hardware not compatible ccc.ggg73 1 1,364 06-10-2017, 09:10 AM
Last Post: curlymo
  Standalone but SSDP brenner23 6 2,246 04-16-2017, 11:34 PM
Last Post: brenner23
  [Solved] pilight ssdp celle 6 7,842 02-23-2017, 03:22 PM
Last Post: gneandr
  Raspbian jessie - pilight 7 - no pilight ssdp connections found shirocko 20 15,475 01-29-2017, 10:23 PM
Last Post: gneandr
  [solved] No signal with raw data andies 6 2,778 12-25-2016, 09:11 AM
Last Post: andies
  pilight without internet connection terrar 5 3,066 08-12-2016, 09:47 PM
Last Post: terrar
  ssdp discovery clach04 5 4,646 05-23-2016, 04:23 PM
Last Post: pilino1234
  Found Bug? boukehaarsma 8 3,832 01-27-2016, 11:07 PM
Last Post: boukehaarsma

Forum Jump:


Browsing: 1 Guest(s)